Introduction
This guide is designed to help you seamlessly implement the Power BI: Load Data to Power BI Chain Template. Whether you need to load new data, update existing data, or remove data from your Power BI Workspace, this template can help assist you on our journey. It provides clear instructions for navigating through the necessary Power BI setup permissions, application API permissions, and the various advantages of using the Chain Template. By following this guide, you can ensure a smooth and efficient implementation process, making your data tasks in Power BI easier and more effective.
Prerequisites
Chains
Data
- A CSV file with the data is required (The CSV file must not contain Byte Order Mark)
- A list of Column Names and respective datatype is essential
Additional Information for Power BI Setup
- Confirm the user account has a Power BI Pro license or higher with permissions to make changes in the Azure account
- Sign in to the Azure Portal
- Select the Microsoft Entra tenant by selecting your account in the upper-right corner of the page
- Select App Registrations.
-
- In App Registrations, select New Registration
-
- Fill out the following fields:
- Name - Give your application a name
- Supported account type - Select who can use the application
- Fill out the following fields:
-
- Select Register. After your app is registered, you will be directed to your app's overview page
- In the overview page, locate the Application (Client ID) and the Tenant ID and store this information in a secure location, you will need these to help connect Workiva to Power BI
API Permissions for Power BI
- Adjust permissions of the Power BI application through with the right hand panel
- Expand Manage
- Navigate to API permissions
- Ensure the following API permissions are selected.
- Ensure the following API permissions are selected.
Redirect URIs
- Adjust permissions of the Power BI application through with the right hand panel
- Expand Manage
- Navigate to Authentication
| Field | Value |
|---|---|
| Azure URI | https://h.app.wdesk.com/s/wdata/oc/app/oauth/callback |
| Field | Value |
|---|---|
| Azure URI | https://h.eu.wdesk.com/s/wdata/oc/app/oauth/callback |
| Field | Value |
|---|---|
| Azure URI | https://h.apac.wdesk.com/s/wdata/oc/app/oauth/callback |
| Field | Value |
|---|---|
| Azure URI | https://h.ca.wdesk.com/s/wdata/oc/app/oauth/callback |
Once you have successfully configured the Power BI permissions, review the Connector to Power BI to set up the Power BI Connector.
Deploy the Chain
The Power BI: Load Data to Power BI is located in the Workiva Chains section of the Templates screen.
Here's how to find it:
- In Chain Builder, go to the Templates tab
- Select Workiva Chains from the menu at the top
- Search for Power BI: Load Data to Power BI Chain Template at the top right and open the template
After locating your template, configure it for your workspace using the runtime inputs listed below.
Note: For detailed instructions on creating a chain from a template, see the Create and Manage Chains article.
Note: This integration user requires appropriate permissions for the commands the connector performs, such as Owner of the spreadsheets or workspace it interacts with.
Runtime Input
| Runtime Input | Description | Field Type | Required? |
| PBI Workspace ID | This is the variable to hold the Power BI workspace id. ID is for workspaces that are separate from your personal PBI workspace. It is located after "/group/" in the URL. | TextField | Yes |
| PBI Dataset ID | This is the variable that holds the existing PBI dataset ID. This can be found within PBI, after "/datasets/" in the URL. This is the dataset we wish to update with new data or delete. | TextField | No |
| PBI Table Name | This is the table name of the table in the dataset that you'd wish to add data to in Power BI. | TextField | Yes |
| Data File | CSV file that you want to bring into Power BI. | FileField | No |
| Add to existing_create new_or delete dataset |
Choice between adding to an existing dataset in Power BI, creating a new dataset to load to, or deleting a dataset. Options
|
DropdownField | Yes |
More About the Chain
To effectively run the chain process as well as to start seeing results, the associated Power BI workspace will need to align with their respective variables within Chains.
Here’s how to input the Table IDs to their respective Runtime Input in the Power BI: Load Data to Power BI Chain
- Navigate to your enabled Power BI: Load Data to Power BI Chain.
- Edit the Runtime Inputs by double clicking on the Command
- Update the respective Table IDs and Workspace IDs located in Power BI in the Runtime Inputs Command
Note: Please be aware, this template requires additional user in a Command downstream in a pipeline.
Within the Create Dataset Command, the user will need to input and configure the dataset columns and respective data type prior to continuing to run the chain.
- Edit the Create Dataset by double clicking on the Command
- Under Columns select ADD and populate the Name and Data Type of the columns.
Note: Be sure to replace the first "CHANGE_ME" column before moving on. Each command only allows 70 Columns. Tables with more than 70+ columns will need to be rejoined within Power BI.
Troubleshooting
The following steps can be used to troubleshoot issues with the chain template:
Chain Execution Errors
CSV containing Byte Order Mark (BOM)
The Power BI commands are unable to load and process CSV files with BOM. To remove the BOM please see the following trouble shooting tips:
For Visual Studio Code (VS Code):
- Open your CSV file in VS Code.
- Click on the encoding displayed in the bottom right corner of the window (it might say "UTF-8 with BOM").
-
A dropdown menu will appear. Select UTF-8. This usually removes the BOM on the next save. You might need to go to File > Save As and ensure "UTF-8" is selected in the encoding dropdown.
For Notepad++ (Windows):
- Open your CSV file in Notepad++.
- Go to the Encoding menu in the top toolbar.
- Select Convert to UTF-8 without BOM.
- Save the file (File > Save).