Error
TLS is enabled but the SMTP server does not support STARTTLS.
TLS is enabled but the certificate verification failed.
TLS is enabled but there was an error establishing a TLS connection.
Cause
These errors are triggered by the Email connector's TLS option.
They point to one of the following errors in your SMTP server's configuration:
- The specified SMTP server doesn't support STARTTLS.
- The SMTP server’s certificate verification failed or is otherwise invalid.
- The host name in the SMTP server’s certificate is invalid and a TLS connection couldn't be established.
Solution
To resolve these errors, you can disable the TLS option in your Email connector, switch to a different SMTP server, or update your current SMTP server to comply with the TLS requirements.
If you choose to update your current server:
- Check that it supports TLS.
- Verify that your certificate or certificate chain is valid.
- Verify that the host name in the SMTP server's certificate is valid.
Note: SMTP servers are not hosted by Workiva and we are unable to advise on their configuration. Please contact your business's IT team when changing these settings.