Fel
Importfel
Duplicerade raddata för nyckelkolumn hittades i tabellen
Duplicerade raddata för nyckelkolumn hittades i importförsöket
Orsak
En -kolumn som är markerad som "nyckel" i din dimensionstabell innehåller en duplicerad rad. Detta upptäcks vanligtvis när en anslutning uppdateras.
Obs: Nyckelkolumner kan endast innehålla unika värden.
Lösning
Du måste ta bort den duplicerade raden från ditt dataset
Det finns två sätt att hitta den duplicerade raden i Workiva:
- Skanna dina källdata manuellt.
- Skapa en ny fråga som kopplar samman dimensionstabellen med det dataset du försöker ladda till nyckelfältet. När du filtrerar på Sheet.account Is Not Null kommer resultaten att vara de värden som redan finns i kolumnen "key".
Obs: Den här lösningen fungerar bäst när man hanterar kolumner med en nyckel och strängdata. Casting kan krävas för andra datatyper.
Du kan också söka efter dubbletter med hjälp av Microsoft Excel:
- Skapa en ny fråga i Workiva som hämtar alla data från dimensionstabellen och exportera den till Excel som en CSV-fil. Kopiera separat alla rader i datasetet som importeras (dvs. datasetet som gick inte) och klistra in dessa rader i CSV-filen. Detta skapar en fullständig tabell över dina data - inklusive de dubbletter som utlöser felet. Därefter skapar du en ny kolumn vars värden är CONCATENATEd av alla nyckelkolumner och villkorligt formaterar den för att markera dubbletter.
Obs: Du kan sortera kolumnen efter cellfärg för att flytta alla duplicerade rader till toppen.