Erros
O comando "Execute SuiteQL Query" do conector do NetSuite Analytics às vezes retorna resultados inesperados quando comparado ao conjunto de dados de origem no NetSuite. Embora nenhum erro seja exibido, uma comparação entre os dois conjuntos de dados revelará que alguns conjuntos de dados estão "ausentes", enquanto outros são exibidos várias vezes.
Causa
A API do NetSuite limita cada resposta do Execute SuiteQL a 1.000 registros, portanto, o solicitante precisa enviar uma solicitação de acompanhamento com um deslocamento para buscar o restante dos resultados. O desafio disso é que cada solicitação de acompanhamento é executada novamente como uma solicitação original pelo NetSuite, o que pode fazer com que o mesmo registro apareça várias vezes, muitas vezes em um local diferente.
Solução
Para resolver esse problema, vá para o NetSuite e adicione uma cláusula ORDER BY que aponte para um campo exclusivo em sua consulta. Isso garante que cada registro tenha sempre a mesma posição no conjunto de resultados.
Para saber mais, consulte: