Błędy
Polecenie "Execute SuiteQL Query" konektora NetSuite Analytics czasami zwraca nieoczekiwane wyniki w porównaniu ze źródłowym zestawem danych w NetSuite. Chociaż nie jest wyświetlany żaden błąd, porównanie dwóch zestawów danych ujawni, że niektórych zestawów danych "brakuje", podczas gdy inne są wyświetlane wielokrotnie.
Przyczyna
Interfejs API NetSuite ogranicza każdą odpowiedź Execute SuiteQL do 1000 rekordów, więc żądający musi wysłać kolejne żądanie z przesunięciem, aby pobrać pozostałe wyniki. Wyzwanie polega na tym, że każde kolejne żądanie jest ponownie uruchamiane przez NetSuite jako oryginalne żądanie, co może skutkować wielokrotnym pojawieniem się tego samego rekordu, często w innym miejscu.
Rozwiązanie
Aby rozwiązać ten problem, przejdź do NetSuite i dodaj klauzulę ORDER BY, która wskazuje na unikalne pole w zapytaniu. Dzięki temu każdy rekord będzie miał zawsze tę samą pozycję w zestawie wyników.
Aby dowiedzieć się więcej, zobacz: