Błąd
Błąd importu
Zduplikowane dane wiersza kolumny klucza znalezione w tabeli
Zduplikowane dane wiersza kolumny klucza znalezione podczas próby importu
Przyczyna
Kolumna oznaczona jako "klucz" w tabeli wymiarów zawiera zduplikowany wiersz. Zazwyczaj jest to wykrywane podczas odświeżania połączenia.
Uwaga: Kolumny klucza mogą zawierać tylko unikalne wartości.
Rozwiązanie
Będziesz musiał usunąć zduplikowany wiersz ze swojego zbioru danych; niestety nie podano dokładnej lokalizacji zduplikowanego klucza.
Istnieją dwa sposoby na zlokalizowanie zduplikowanego wiersza w Workiva:
- Ręcznie przeskanuj dane źródłowe.
- Utwórz nowe zapytanie, które łączy tabelę wymiarów z zestawem danych, który próbujesz załadować do pola klucza. Gdy filtrujesz po Sheet.account Is Not Null, wynikami będą wartości, które już znajdują się w kolumnie "key".
Uwaga: To rozwiązanie działa najlepiej w przypadku kolumn z pojedynczym kluczem i danych łańcuchowych. W przypadku innych typów danych może być wymagane rzutowanie.
Możesz także skanować w poszukiwaniu duplikatów za pomocą programu Microsoft Excel:
- Utwórz nowe zapytanie w Workiva, które pobierze wszystkie dane z tabeli wymiarów i wyeksportuj je do programu Excel jako plik CSV. Osobno skopiuj wszystkie wiersze importowanego zbioru danych (tj. zbioru danych, który zawodzi) i wklej je do pliku CSV. Spowoduje to utworzenie pełnej tabeli twoich danych - w tym duplikatów, które powodują błąd. Następnie utworzysz nową kolumnę, której wartości są KONKATENATEM wszystkich kolumn kluczowych i warunkowo sformatujesz ją, aby wyróżnić duplikaty.
Uwaga: Możesz posortować kolumnę według koloru komórki, aby przenieść wszystkie zduplikowane wiersze na górę.