Feil
Importfeil
Dupliserte nøkkelkolonnelinjedata funnet i tabellen
Dupliserte nøkkelkolonnelinjedata funnet i importforsøket
Årsak
En -kolonne merket som "key" i dimensjonstabellen inneholder en duplikatrad. Dette oppdages vanligvis når en tilkobling oppdateres.
Merk: Nøkkelkolonner kan bare inneholde unike verdier.
Løsning
Du må slette den dupliserte raden fra datasettet ditt; dessverre er ikke den nøyaktige plasseringen av den dupliserte nøkkelen oppgitt.
Det finnes to måter å finne den dupliserte raden på i Workiva:
- Skann kildedataene manuelt.
- Opprett en ny spørring som kobler dimensjonstabellen til datasettet du prøver å laste inn i nøkkelfeltet. Når du filtrerer på Sheet.account Is Not Null, vil resultatene være de verdiene som allerede finnes i "key"-kolonnen.
Merk: Denne løsningen fungerer best når du har å gjøre med enkeltnøkkelkolonner og strengdata. Casting kan være nødvendig for andre datatyper.
Du kan også skanne etter duplikater ved hjelp av Microsoft Excel:
- Opprett en ny spørring i Workiva som henter alle data fra dimensjonstabellen, og eksporter den til Excel som en CSV-fil. Kopier alle radene i datasettet som skal importeres (dvs. datasettet som feiler), og lim disse radene inn i CSV-filen. Dette oppretter en fullstendig tabell med dataene dine - inkludert duplikatene som utløser feilen. Deretter oppretter du en ny kolonne med verdier som er CONCATENATEd av alle nøkkelkolonnene, og formaterer den betinget for å markere duplikater.
Merk: Du kan sortere kolonnen etter cellefarge for å flytte alle dupliserte rader til toppen.