クラシックファイルタイプは、2021年1月をもって使用不可となりました。クラシックファイルを移行するか、PDFをダウンロードすることができます。 詳細を見る

timeout on API call

回答済み
0

コメント

11件のコメント

  • 正式なコメント
    Wayne Paffhausen

    Hello Vince O'Leary,

    Currently it is a connector/platform limitation of 2minutes.  Generally in a RESTful response the activity is to be stateless you do not want to wait long for an acknowledgement.

    You could currently create a ticket for an enhancement for a timeout option to be added.

    Thank you,
    Wayne

  • Wayne Paffhausen

    Hi Pam,

    Can you share a screen print from Chains of the error message you are receiving?  What end point are you calling?

    Thank you,
    Wayne

    0
  • Pam Thomas
    0
  • Pam Thomas

    Let me know if you need any additional information.

     

    Pam

    0
  • Wayne Paffhausen

    Hi Pam,

    I apologize for the delay... Just a few other questions to quickly level-set.

    1. Can you run this RestFUL statement from another tool, like PostMan or cURL? 
    2. If so; how long does it take?

     

    0
  • Pam Thomas

    Wayne

    My tool that I have is timing out too.

    So is there a way in Workiva to increase the timeout parm?  I may need 6 minutes.  Is that even doable?

    I am also thinking about splitting my results into 2.  Is there a way then to combine those files into one when importing to a table?  I am very new to Workiva so not sure if that will even work.

    Thanks

    Pam

     

     

    0
  • Wayne Paffhausen

    Hi Pam,

    If your other tool is timing out as well, then the Workiva platform isn't the limiting factor.  It sounds like you will need to work within the confines of the vendor you are pulling data from.  If splitting your data into smaller sets is possible then the Workiva platform does have the ability loop, stack/combine files for occasions like this. 

     

    0
  • Pam Thomas

    well my tool times out at 1 minute; workiva times out at 2 minutes.  Is there a way to extend the timeout in workiva?  I tried on the HTTPS call but doesn't seem to have an affect

    That is my basic question.

    Thanks.

     

     

    0
  • Wayne Paffhausen

    Pam,

    Currently there is no way to change the default wait time.  

    0
  • Tony Scalese

    Pam,

    The timeout appears to be controlled by the system to which you are attempting to connect.  This appears to be a state government application which may have additional security layers in place that impact the ability to use this REST API (think IP filtering).  If you have a contact for this system, I would reach out and ask if there is any documentation for the API.  Review it for timeout settings as well as IP whitelisting.  Unfortunately as Wayne noted, this isn't a problem on the Workiva side so there isn't much we can do to help.  

    Sorry!

    Tony

    0
  • Vince O'Leary

    Experiencing the same issue as this user, exactly at the 2 min mark. 

    (Client.Timeout exceeded while awaiting headers) 



    As the target server in our case is internally owned, can confirm the 2 min limitation is definitely set by the Client (workiva) and not by the server, which aligns with the error message stating 'Client.Timeout exceeded'. 

    As it's been a while since this original post, curious, is there a way to increase the maximum Client.Timeout value, say from 120 seconds to 480? If not, is there another recommended resolution to avoid this error when needing to wait for longer-running processes to complete? 

    0

サインインしてコメントを残してください。