クラシックファイルタイプは、2021年1月をもって使用不可となりました。クラシックファイルを移行するか、PDFをダウンロードすることができます。 詳細を見る

How to get superscripts in a spreadsheet to link through to a document

回答済み
0

コメント

9件のコメント

  • Mike

    Hi Tori,

    Thanks for the question. If I follow you correctly, the superscripts in the destination links in a table cell are not showing with the superscript formatting after transitioning to next gen, is that right? I certainly wouldn't expect that. I'll keep doing a little digging on my end but do let me know if I've missed the mark or you have any follow-ups for me.

    Thanks again for reaching out, and if you do need immediate assistance don't hesitate to call us 24/7 at 1.800.706.6526 or by email at support@workiva.com. Happy Friday in the meantime and chat with you soon. Cheers!

    0
  • Tori Garcia

    Hi Mike - that is correct. Superscripts in a spreadsheet are not keeping their formatting through to the destination in a classic document table.

    Thanks!

    0
  • Mike

    Gotcha Tori Garcia. Thanks for clarifying.

    I tested to confirm, but in this case, when you link from a next gen Spreadsheet to a classic Document, the formatting of the superscript (or other formatting) will NOT flow through. If you were to link between next gen content specifically, then the formatting would follow.

    A way to possible get around this in a classic Document is to insert a special character into the Spreadsheet link instead of a formatted number. To do this, follow these steps:

    1. In the Spreadsheet cell, double-click and select Insert > Symbol > Symbol Library.
    2. From here, choose the Superscript one option
    3. Once this is added to your cell, the character will flow through to your destination.
      Source

      Destination

    This option will only work for the values of 1, 2, or 3, as those are the only superscript number symbols available directly from the symbol menu. However, if you needed more values, you could insert a unicode character directly into your cell as an option.

    Inserting a unicode
    This process seems technical, but is really pretty simple. It can be done by using the following key command: Alt+X+Character Code. For the Character Code part, you just type the code you want for the character you want. Here's a list of codes superscript unicodes:
    https://www.fileformat.info/info/unicode/block/superscripts_and_subscripts/list.htm

    In this example, for superscript 4 (⁴) you can type Alt+X+2074 and the character should now appear.

    Hopefully one of these two options work for you. If you do have any questions for me, let me know and I'll be happy to help. Thanks again and have a super day in the meantime. Cheers!

    0
  • Tori Garcia

    Hi Mike,

    Thank you for looking into this and clarifying! These options should work for us. I appreciate the quick response!

    Best,

    Tori

    0
  • Mike

    Don't mention it, Tori! Glad that will work for you. Keep staying awesome :)

    0
  • Debbie Angelico

    Hi Mike,

     

    I'm using Next Gen documents and spreadsheets and the formatting Tori mentioned (superscript in a spreadsheet) is not flowing through to the Document. Do you have any suggestions?

    Thanks,

    Debbie

    0
  • Mike

    Hi Debbie Angelico!

    Yes, I do have some suggestions for you here.

    First, I should have updated this post to let folks know that items like superscripts (and subscripts) will flow through link formatting now in next gen. To get this to work, you'd need to do two things.

    1. Make sure the value format in both the source Spreadsheet and Document destination is Text, and;
    2. Make sure the check box for "Use link formatting from source" is checked in the Link Formatting panel

    If this is done, the superscript should display in your Document the same as it does in your Spreadsheet. If the link's value format were something other than Text, it would NOT.

    Let me know if this is not the case for you, or I've missed the mark. Thanks for your contributions and chat with you soon!

    0
  • Amelia Kelly

    I am not always given the option of "use link formatting from source" even when the format is text.  Why isn't this always available? Even if I paste from a cell that has this option, it disappears when pasted.  

    0
  • Mike

    Hi Ameilia!

    Apologies for the delay here. Was doing a little digging on this, and not sure if this is the case for you but there is an exception to use link formatting from source. Paragraph formatting only flows-through from the source if the destination includes the first character of the paragraph from the source. This is mentioned briefly on this article: https://support.workiva.com/hc/en-us/articles/360046179071-Format-linked-values. In addition, if "Include link formatting" in the source link is not selected, you cannot see it in the destination either.

     
    Not sure if either of those are possible reasons for why you are seeing what you see, but wanted to share my findings there. Holler if you do have any questions for me. Thanks and chat soon!
    0

サインインしてコメントを残してください。