Errors
The NetSuite Analytics connector's "Execute SuiteQL Query" command will sometimes return unexpected results when compared to the source dataset in NetSuite. Though no error is displayed, a comparison between the two datasets will reveal some datasets are "missing" while others are displayed multiple times.
Cause
NetSuite's API limits each Execute SuiteQL response to 1000 records, so the requestor needs to send a follow-up request with an offset to fetch the rest of the results. The challenge with this is that every follow-up request is re-run as an original request by NetSuite, which can result in the same record to appearing multiple times, often in a different place.
Solution
To resolve this issue, go to NetSuite and add an ORDER BY clause that points to a unique field in your query. This ensures each record will always have the same position in the result set.
To learn more, see: