Fehler
Der Befehl "SuiteQL-Abfrage ausführen" des NetSuite Analytics Connectors liefert manchmal unerwartete Ergebnisse, wenn er mit dem Quelldatensatz in NetSuite verglichen wird. Obwohl kein Fehler angezeigt wird, zeigt ein Vergleich zwischen den beiden Datensätzen, dass einige Datensätze "fehlen", während andere mehrfach angezeigt werden.
Ursache
Die API von NetSuite begrenzt jede Execute SuiteQL-Antwort auf 1000 Datensätze, so dass der Anfragende eine Folgeanfrage mit einem Offset senden muss, um die restlichen Ergebnisse abzurufen. Das Problem dabei ist, dass jede Folgeabfrage von NetSuite erneut als Originalabfrage ausgeführt wird, was dazu führen kann, dass derselbe Datensatz mehrfach erscheint, oft an einer anderen Stelle.
Lösung
Um dieses Problem zu beheben, fügen Sie in NetSuite eine ORDER BY-Klausel hinzu, die auf ein eindeutiges Feld in Ihrer Abfrage verweist. Dadurch wird sichergestellt, dass jeder Datensatz immer die gleiche Position in der Ergebnismenge hat.
Weitere Informationen finden Sie unter: