クラシックファイルタイプは、2021年1月をもって使用不可となりました。クラシックファイルを移行するか、PDFをダウンロードすることができます。 詳細を見る

Copy documents and preserving links

回答済み
0

コメント

8件のコメント

  • Mike

    Howdy Megan Daniell!

    Good news, there is indeed a way to copy a document in just that method. Here's how:

    1. Right-click on the document from Home and choose Copy
    2. From the pop-up window for Step 1 of 2: Review Files, select your single document and click Next
    3. From next window for Step 2 of 2: Select Settings, under Link Settings, check the box for "Keep Links to Linked Files"

    4. When the copy is finished,  you can investigate the destination links in the newly copied document, which should have the same source as the previous version.

    Let me know if you need any help on the above, or have any other questions for me. Have an awesome day in the meantime. Cheers!

    2
  • Rachel McClintock

    Is this possible to do with Classic documents? I don't see that option. 

    0
  • Mike

    Welcome to the Community, Rachel! Happy to answer your question.

    You are correct, the "Link Settings" options shown above are only available for next gen file types when copying. Let me know if you have any follow-ups for me, or need anything else. Thanks for your contributions and have a super day!

    0
  • Deborah Tozato

    Hello!

    Do you need any sort of special permission to copy a file?

    For example, if someone is only an editor, do we have to change their permission to workspace owner or even administrator for them to be able to copy the file?

    Thank you!

     

     

    0
  • Mike

    Hello and welcome to the Community, Deborah!

    Yes, to have the Copy option, by default for this setting is restricted to only Workspace Owners. There is an option to set this to allow all users to copy, not just Workspace Owners. If you'd like to pursue that option, let me know and I can get that going on our end.

    In the meantime, let me know what questions you have or if you need anything else. Thanks again and chat soon!

     

    0
  • Mike

    Hello and welcome to the Community, Megha!

    I did a little digging and think I might know why this is happening for you.

    These unpublished links post copy happen when links are “chained” between documents. For example, Document1 has a source link (source1) with a destination in Document 2. Document 2 uses that destination in a formula, and the formula is a source link (source2). When we copy those documents, the sources get created and published, then the destination receives a new value, at which point the formula recalculates the value and source2 becomes unpublished. This can happen in increasingly complex ways, but the above is perhaps the simplest case.

    I can also say that there is work being done to help address this is but in the meantime, publishing after the document has been copied is the justifiable, in this case.

    Does the above seem possible in your case? Let me know if I've missed the mark here, or you have any follow-ups for me. Thanks much for your contributions and have a great rest of your day!

    0
  • Diana Florez

    How do we setup permissions to allow Editors to copy, not just Workspace Owners? As mentioned above.

    0
  • Elena Weber

    Hello and welcome to the community, Diana!

    The easiest way to do this would to be grant the Editors the Copy Manager role. This grants that ability without giving access to administrative features. Here’s an article on how to Change a member’s role.

    Let me know if you have any follow-ups or need anything else.

    0

サインインしてコメントを残してください。