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Have a smooth journey into multi-channel 
publishing and make an impression in all outputs
Welcome to the fourth edition of The Widget. It’s not bigger (because we all don’t 
want it bigger!) but it is hopefully better - just containing the core information you 
need to make a success of your design right through to filing day.

The big difference is that for this Widget we are practicing what we are preaching. 
We created this Widget in the Workiva platform and exported to Adobe InDesign 
software. Our format is landscape (much better for screens). And we also created 
XHTML - the full round trip. 

Please take time to look at the Core Essentials. The information here is so 
important in your Workiva journey and will truly save you time once you start your 
project.

Welcome

For reports that need to adhere to the 
European Single Electronic Format 
(ESEF), tips are shown here. 

Workiva is for everyone!
• Be at home with InDesign software or stay at home in the Workiva platform

• Format compatibility

• Easy amends and versions control

• See your design in XHTML whenever you want

• No downtime for all users and designers

Key takeaways are test your design early and often in XHTML and make sure you 
are comfortable with the process. The Core Essentials section is a must for a 
successful integration. 

All information, content, and materials available in this document 
are for general informational purposes only. The content on this 
posting is provided "as is;" no representations are made that the 
content is error-free or up to date. Designers should test their 
design in XHTML often and keep back up files at all times.
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Key Resources
Advanced workflow
This session is all about the run up to filing together with great tips. For example 
what to do with images when maintaining a version for print and web.

• Last minute editing

• Complex image methods

• Quickly switching from print to web modes in InDesign software

All things typographic
Typography is discussed in this workshop so things like widow management, font 
licensing and justified text when publishing to the web.

• Workflow

• Design

• Technical

How to have a great submission
Although this workshop prepares a file for the criteria of the ESEF mandate, it is 
relevant to all designers as it goes through managing headers and footers, testing 
your IDML file and scenarios when you might need to add extra content not in the 
Workiva platform

• XBRL review

• Report format review

• On the day of filing

See our workshops here

Our workshops

Introduction to the whole process
This workshop looks at the whole process of exporting content from the Workiva 
platform to InDesign software together with the inclusion of XBRL™ tagging. The 
mandate used in this webinar is the ESEF mandate where iXBRL™ tags are added 
to the main financial statements but is still relevant to those clients using other 
taxonomies.

• Demonstration of the integration between InDesign software and the Workiva 
platform 

• Overview of features and functionality

Design considerations for the web 
This fun session looks at how print design needs to adapt for online viewing. 

• Is it the death of the spread?

• Is there a role for the divider?

• Typography for multi-channel publishing

• Does XBRL affect design?

• Designing for XHTML

Back to basics guide for designers new to Workiva
This workshop takes everything a bit slower for designers new to multi-channel 
publishing. 

• The eight steps you need for smooth multi-channel reporting

https://event.on24.com/eventRegistration/EventLobbyServlet?target=reg20.jsp&referrer=https%3A%2F%2Fsandbox.wdesk.com%2F&eventid=2963641&sessionid=1&key=025D19479CFD8620C82EE6A514EF0139&regTag=2037576&V2=false&sourcepage=register
https://event.on24.com/eventRegistration/EventLobbyServlet?target=reg20.jsp&referrer=https%3A%2F%2Fsandbox.wdesk.com%2F&eventid=2963641&sessionid=1&key=025D19479CFD8620C82EE6A514EF0139&regTag=2037576&V2=false&sourcepage=register
https://event.on24.com/eventRegistration/EventLobbyServlet?target=reg20.jsp&referrer=https%3A%2F%2Fsandbox.wdesk.com%2F&eventid=2963641&sessionid=1&key=025D19479CFD8620C82EE6A514EF0139&regTag=2037576&V2=false&sourcepage=register
https://event.on24.com/eventRegistration/EventLobbyServlet?target=reg20.jsp&referrer=https%3A%2F%2Fsandbox.wdesk.com%2F&eventid=2963641&sessionid=1&key=025D19479CFD8620C82EE6A514EF0139&regTag=2037576&V2=false&sourcepage=register
https://event.on24.com/eventRegistration/EventLobbyServlet?target=reg20.jsp&referrer=https%3A%2F%2Fsandbox.wdesk.com%2F&eventid=2963641&sessionid=1&key=025D19479CFD8620C82EE6A514EF0139&regTag=2037576&V2=false&sourcepage=register
https://event.on24.com/eventRegistration/EventLobbyServlet?target=reg20.jsp&referrer=https%3A%2F%2Fsandbox.wdesk.com%2F&eventid=2963641&sessionid=1&key=025D19479CFD8620C82EE6A514EF0139&regTag=2037576&V2=false&sourcepage=register
https://event.on24.com/eventRegistration/EventLobbyServlet?target=reg20.jsp&referrer=https%3A%2F%2Fsandbox.wdesk.com%2F&eventid=2963641&sessionid=1&key=025D19479CFD8620C82EE6A514EF0139&regTag=2037576&V2=false&sourcepage=register
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What’s new
Constantly improving productivity across multi-channels to help creativity. Listed 
here are the updates from version 3 of the Widget.

Updated style pallet
There is now a search bar in the Styles dropdown. Start typing and all the relevant 
styles will appear. This makes it much quicker to find styles. Remember you can 
order your styles in the Edit Style Guides tab. 
Because of this update, designers can now organise their styles alpha numerically 
based on relevance and usage.

Updated style management
Automated styles are now based on the custom style that they came from originally. 
You can control aspects of the propagated styles by editing the route style in both 
character and paragraph pallets.

Bulleted list
At the moment bulleted lists are overrides and will create an auto-generated style. 
Best practice is to create a dedicated style for bulleted and enumerated lists and 
apply the bullets as an override in the normal way.

When you export to InDesign software, the bulleted list styles will appear together 
in your Style pallets with some random numbers after them. This is because the 
style is auto-generated. You can quickly find and change their attributes. Just to 
note, do not change style names.

Wingdings and dingbats
If using wingdings and dingbats please test them throughout the whole process to 
be sure they are rendering as expected.

Discrepancy report
This report helps show any issues when converting IDML to XHTML in the Workiva 
platform. Its purpose is to alert designers to items that are not supported in the 

IDML>XHTML conversion process. Most warnings are to do with XHTML but 
some are to preserve the integrity of the XBRL. For example things like linked 
images will flag up warnings. The report is created when you convert your file to 
XHTML and sits alongside the XHTML file ready to view. This report does not pick 
up everything so these guidelines should still be followed closely. 

ESEF annual reporting starter pack
This pack contains

• ESEF mandate checklist

• ESEF submission checklist

• Design agency checklist

• Full navigation to help files

• Annual report template with 60 preset styles for use in the Workiva platform and 
InDesign software

Find this at marketplace.workiva.com

Plugin
The new Workiva Integration Plugin for InDesign Software has been provided so 
that designers now have a validation tool that identifies issues within an InDesign 
software document that would corrupt or are otherwise not be appropriate for 
conversion into XHTML. This plugin is easy to import in both Mac and PC versions 
of InDesign and writes a report at the click of a button. 

Have you considered partnering with us? 
We have created a partnership programme especially for design teams. There are 
many benefits including certification, access to your own Workiva workspace and 
joint marketing opportunities. 

See the Plugin feature here

https://marketplace.workiva.com/en-us/templates/esef-annual-reporting-starter-pack
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For the Workiva platform to interact well with the InDesign software, you need to 
set up your report correctly. Taking the time now really will reap benefits later on in 
the project. 

Setting the document outline
The document outline represents the structure of the ICMLs. There is one ICML for 
each section or child of section. 

Create your style pallet
All content in the Workiva platform should have a style attached to it. For ICML 
export the ‘Normal’ default style will be converted to the Bodytext style. See our 
next section for detailed

Headers and footers
Headers and footers can be generated in the Workiva platform however they do 
not export via ICML to the InDesign software. The export can only send content in 
between the grey dashed lines at the top and bottom of each page of the document.

Typesetting
Typesetting takes place in the Workiva platform not in the InDesign software. In 
multi-channel publishing, best practice is to not use a soft return. A soft return is 
when you press Shift Enter. This creates a line break rather than a paragraph break. 
You can see your soft and hard returns but pressing the Show/hide non printing 
characters on your Edit ribbon.

If words are not to be broken, for example a name of a director, then use a non-
breaking space in between. Go to Insert>Symbol>Special Characters>Non-breaking 
Space. There is also a keyboard shortcut.

Landscape v portrait
Traditionally most annual reports use a portrait presentation but increasingly 
landscape is being used for better onscreen consumption.

Spreads
The concept of spreads is limited within the current iXBRL inline reader. 
Designers need to be careful when relying on a spread to convey information 
as this will be broken into two separate consecutive pages. It is possible with 
the help of web development to present spreads within the inline viewer so 
please talk to your web team if spreads are required as part of the inline viewer 
experience.

Mirrored margins
Often, in the case of a document going to print, the inner margin will be 
wider than the outer margin because of the act of stitching. This can present 
a problem of readability when presented digitally in both PDF and XHTML. 
Consider adjusting margins for digital presentation. 

Document setup in Workiva
C O R E  E S S E N T I A L S

Formats 

It is important in a multichannel publishing scenario to establish the page format, 
margins and gutter measurements right from the outset. A prominent reason for 
doing this, is the limitation in ICML of adjusting table and column widths. Therefore, 
these need to be the same in the Workiva platform as it is in the InDesign software. 

Things to consider:

Style Guide information.
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Tables
C O R E  E S S E N T I A L S

Tables in the Workiva 
platform must be 
set to the correct 
width. This cannot 
be changed in the 
InDesign software.

Line feed affects row 
height differently 
in XHTML and the 
InDesign software so 
it is a good idea to set 
the line-height to be the 
same as the font size for 
styles used in tables. 

All cell styles in the 
InDesign software are 
auto-generated. They 
are based on No-Rule 
so heights can be 
controlled from here 
once in the InDesign 
software. 

Cell styles
The Workiva platform does not use cell 
styles. The ICML and XHTML exports 
contain an algorithm that summaries 
design parameters into cell styles for 
InDesign and CSS respectively. 

Inheritance
The ICML export now uses the concept 
of inheritance or ‘Based on’ in both 
character and paragraph styles. This 
is extremely useful for designers to 
be able to control large amounts of 
styles efficiently. Particularly the auto-
generated styles. 

Cell types in Workiva
Designers new to the Workiva platform 
need to be aware that the cells are 
active in terms of content formatting. 
For instance, cells can be nominated 
as accountancy, text or number 
with decimal places automatically 
attributed. 

Table and column widths
Designers need to be aware that table 
and column widths cannot be altered 
in linked ICMLs. These need to be 
correct in the Workiva platform. 

Cell height management
There is a substantial difference 
between the way the InDesign 
software and XHTML handle line 
height in the first item within a table 
cell.

In order to make adjustments so 
that the XHTML looks correct, 
designers should consider these two 
workarounds.

1. Make the line height of the table 
paragraph style, the same as the font 
size.

2. Adjust Padding Top and Padding 
Bottom of the ‘No-Rule’ style in the cell 
styles.

Coloured brackets
You may see coloured brackets around 
financial figures when you place your 
ICML files. These are placeholders for 
the XBRL tagging and do not hinder 
your design capabilities at all. You can 
just ignore them. 

XBRL tagging will fail if these observed 
regions (square brackets[]) are split. 
This can happen when using the split 
story feature of the InDesign software. 
Designers need to be careful when 
using this feature.



8

Style guides
A style guide is a set of standards for the design of a document that ensures 
formatting consistency throughout and/or across multiple documents.

For smooth export to Adobe InDesign software it is desirable for all the content in 
the Workiva platform to have an associated custom style applied to it. 

There are two ways a designer can do this

1. Set up the styles in the Workiva platform and export to the InDesign software via ICML

2. Create the styles in the InDesign software and import back to the Workiva platform via 
Microsoft Word document/software

Best practices for creating and using style guides
You need to consider styles for all your content. When choosing a style name, it 
is a good idea to choose a name that reflects the use of the style, for example 
CaptionSmallBlue or TableTextBold. This will help everyone on the team understand 
the structure and apply the correct style to the content. 

Efficiency of style naming gives structure and makes it easier for the user to apply 
them. So when constructing a style, think about its structure. Consider using a stem 
to indicate a group of styles for example body or table and then indicate secondary 
aspects thereafter such as text, figs, bold.

Stem Level Nature Modification
Table Text Bold Indent

Table Figs
Caption Small Italic Centre

Style names can contain letters and numbers but should always start with a letter. 
For example, Heading1 is good. 1Heading will not work. This is to do with the 
specification of CSS (Cascading Style Sheets).

Characters such as - !@#$%^&*()_+-={}:”<>?[];’,./`~ etc and spaces must be avoided. 

Once styles have been created, they can be locked in the Workiva platform to 
stop them being changed accidentally. In the Style Guide Editor, font, font size, 
font colour, emphasis, alignment, indentation and spacing can all be locked 
independently. 

Style setup
C O R E  E S S E N T I A L S

DO’S
Create styles in Workiva or import them from InDesign

Create styles for both Workiva content and non-Workiva content (alien 
content) such as picture captions, running headers, page tabs, etc. 

All style names should start with a letter with no spaces and have no 
special characters (e.g., &#@)

Name sub-headings in order of font size so everyone can understand

Indents and bullets need to be set in a style

Add a custom style to all content

DON’TS
Try not use overrides - create a separate style

Tabs must not be used - the web does not understand a tab
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InDesign styles remain king 
You can adjust styles in the InDesign 
software and these will stay regardless 
of further ICMLs. The only style that 
should be the same in the Workiva 
platform and InDesign is Bodytext 
(spelled like this). For better parity, 
keep the Bodytext attributes identical 
in both platforms.

Take time to set 
up styles properly 
- it really does save 
time later

Importing styles from 
InDesign
If you have an existing InDesign 
document from which you need the 
content and styling, the following 
procedure is a useful way of achieving 
this with the added advantage that 
the content from the Workiva platform 
can be exported via ICML back to 
that InDesign document without any 
issues.

Step three
Import the Word document into 
the Workiva platform. The styles 
will be imported into the custom 
style pallet. 

You now need to reapply the styles 
to all the content. (We are working 
to improve our import procedure 
so you don’t have to reapply styles).

You should now have your content 
within the Workiva platform in the 
same styles as in your InDesign 
document. Minor adjustments may 
be required to the custom styles in 
the Workiva platform.

Follow these three steps to make sure 
everything runs smoothly.

Step one
Take a good look at your styles 
in the InDesign software and 
make sure they conform to 
web CSS standards in terms of 
nomenclature (no spaces, special 
characters etc). Please do not use 
style folders.

Step two
Copy and paste content from the 
InDesign software to MS Word 
software. The styles will be copied 
across from InDesign. Make 
sure the styles are applied to the 
content within Word if not already 
applied automatically. 

It is best practice not to 
use the ‘Normal’ style 
in the Workiva platform. 
The InDesign software 
can have issues with this 
default style

Turn default ‘Normal’ 
to pink to identify 
content missed

Bodytext is a special 
style and should be 
the same in both the 
Workiva platform and 
InDesign software

If the ribbon is clicked 
in the Workiva platform, 
another style is 
automatically created
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Colour management
C O R E  E S S E N T I A L S

RGB CMYK

HEX

RGB

CMYK

For XHTML, only RGB colours must be 
used as RGB is the only colour format 
supported on the web. The InDesign 
software uses CMYK and Pantone spot 
colours for the printing of ink on paper. 
The web cannot use these colour 
formats as RGB is the default colour 
space of the web. If the InDesign 
software is being used to author and 
this content is to be converted to 
XHTML then RGB (Red, Blue, Green) 
colours must be used.

Converting CMYK to RGB is not 
straightforward. So it is best that 
designers specify RGB in their InDesign 
documents so accuracy is maintained 
and there are no surprises when 
converting.

Hex is another way of describing 
RGB colour in base 8 (hexadecimal). 
Pantone colours (spot) are used in 
printing. The ink used is the actual 
colour specified instead of being 
made up of CMYK colours. They are 
often specified in branding guidelines 
for a corporate colour because of 
their accuracy. It is advisable to 
always check branding guidelines for 
specific colours rather than relying on 
conversion.

All colours need to 
be in RGB for web/
ESEF use

Remember screen 
limitations when 
choosing colours for 
the web. 

Make sure you have 
enough colour contrast 
for good readability for 
all users.
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Fonts
C O R E  E S S E N T I A L S

Licensing
For publishing in XHTML, companies need to own the web usage rights of any font 
weight being used in their iXBRL/XHTML file.

At the moment an iXBRL filing constitutes web usage. It is recommended that 
companies check the licensing status of all fonts they are using. Also, issuers 
cannot rely on suppliers to do this for them or indeed hold such a licence on behalf 
of the issuer. In addition, licensing is based on a per font ‘weight’ basis so if you are 
only using two weights of a font family you only need to comply for those weights. 

If the font is available in the Workiva platform, then the font is open source or has 
the appropriate license in place. We advise designers to check with their client 
regarding font usage if they are not in the Workiva platform.

Open source fonts
Google fonts and other ‘free to use’ fonts may be worth considering not only for cost 
reasons but because they are especially tailored for the web.

Web fonts (woff and woff2)
Web Open Font Format is now the standard for font usage in browsers and OTF and 
TTF fonts will be converted to these formats at upload time or designers can upload 
the fonts in these formats. Supported browsers and versions are below. Discussion 
is taking place re TTF support for older versions of these browsers.

Testing font rendering in browsers
It is important that designers test font rendering in browsers to avoid unexpected 
effects. It is critical that font choices are made with such knowledge. Also, some 
italic font weights and some older sans serif fonts are prone to not looking very 
good when rendered in browsers. We recommend testing fonts early.

Fonts not in the Workiva platform
Please ensure that fonts used in the InDesign software are uploaded with your 
IDML at conversion time. You will need to zip the IDML and font folder for the 
import. If the fonts are available in the Workiva platform, this step is not necessary.

For ESEF, fonts used 
in iXBRL format are be 
converted to base64 
format and embedded 
in the CSS

Custom fonts
These include fonts constructed for licensing reasons or decorative usage within 
text. Please test thoroughly with the round trip process so that you are confident 
that the font construction is suitable for the Workiva platform conversion process.

Renaming of fonts
Please be aware that renaming fonts can render them inoperable or cause them not 
to appear. The Workiva Integration Tool (plugin) log file specifies both familiar and 
postscript names of fonts being used in a document. 

#721
#721
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Widow management
One definition of widow management 
is making sure that the last line of a 
paragraph isn’t a single letter word or 
number. This can look ugly and add 
unnecessary whitespace into a design 
and make the content longer than it 
needs to be. Designers have deployed 
a number of methods over the years 
in the InDesign software to get rid of 
widows.

Typographic layout
C O R E  E S S E N T I A L S

The soft return method
This method is now widely depreciated 
in multi-channel publishing because 
text frame widths can vary in 
responsive layouts. Soft returns can 
have unfortunate consequences 
in such layouts. Browser rendering 
differences can also have the same 
effect.

The kerning method
The previous line(s) to the widow are 
highlighted and the inter-character 
spacing (kerning) is reduced allowing 
the widow to move up onto that line. 
This can be replicated in XHTML but 
can have unforeseen issues in the 
rendering of that content.

The condensing method
As above but instead of kerning the 
characters are condensed in width (eg: 
95%). This can be replicated in XHTML 
but can have unforeseen issues in the 
rendering of that content.

InDesign compositor method
The InDesign software has an 
algorithm that can avoid widows. It is 
not recommended for multi-channel 
use and is not often deployed by 
designers.

Recommendation
Our recommended method of widow 
management is the use of nbsp. This 
can be done in the platform easily and 
is exported via ICML and converted via 
IDML into XHTML.

The non-breaking 
space (nbsp) method
Widely regarded as the best 
way of controlling widows in 
multi-channel publishing. The 
break between words is filled 
with &nbsp; or &#160; effectively 
making two words one word. This 
is ignored by search engines and 
can’t be seen by human readers. 
This also works in responsive 
layouts as it only comes into 
force when a text frame width 
conflicts with that set of words 
forcing all of it onto the next line 
therefore preventing a widow. 
They are also used to keep 
names, place names, company 
names and sets of figures 
together.

A note on design
As we move into a multi-channel 
environment and the use of nbsp is 
accepted as the only way of managing 
widows, designers need to think of 
their designs and allow a little more 
whitespace in their layouts. To get the 
best from multi-channel publishing, 
think XHTML first.
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Hanging indents
Designers may need to experiment 
with the kind of bullets they wish to 
use for bulleted lists. Wingdings, Zapf 
Dingbats or other kinds of font libraries 
can be used if there is a Unicode 
equivalent. These need to be tested 
early to make sure that they translate 
as expected.

If designers wish to use icons or 
images as bullets then they will need 
to edit the CSS in post-production. 
Expertise will be required for this as it 
is not something Workiva can support.

Hyperlinks
External hyperlinks are supported but 
external hyperlinks are not allowed 
under the ESEF requirement. 

Justified text
Whilst not strictly a font issue, it is very 
important to note that XHTML is poor 
at rendering justified text in multi-
column format. The InDesign software 
has very sophisticated tools for 
justification that cannot be replicated 
in XHTML. Please avoid if you can and 
use range left (called ragged right in 
some jurisdictions).

Grep
Grep (global regular expression print) 
is used a great deal by designers to 
control many aspects of typographic 
layout. There are two types of Grep 
within the InDesign software. 

Grep within styles
This is sometimes called 
nested styles. These are regular 
expressions that match certain 
patterns based within content 
that is styled with a particular 
style. The Workiva platform does 
not support Grep within styles. 

Grep within Find and 
Replace
These are regular expressions 
used within the ‘Find and 
Replace’ function of the 
InDesign software and can only 
be used on unlinked content. 
These are permanent alterations 
to the content. This can be done 
after the ICMLs are unlinked in 
preparation for the conversion 
process of IDML>XHTML.

Note to designers - 
external hyperlinks are 
not allowed under the 
ESEF mandate

A good example of the use of Grep in 
the InDesign software with Workiva 
content is changing em dashes (U.S.) 
to en dashes (EU). A nested style can 
be applied to table figure styles to 
make that change on ICML content. 
That Grep will need to be applied with 
Find and Replace when the ICMLs 
are unlinked to make that change 
permanent. 

Lists
Custom styles for lists can now be 
created in the Workiva platform. These 
are still treated as an override but can 
now be identified within the InDesign 
software as that custom list style. 

For IDML export, do not split a bulleted 
item across text frames. The list can be 
in multiple frames but not an individual 
bullet.



14

Many reports will also be printed in addition to any XHTML requirement. In this 
case designers will need to keep two sets of assets (images and charts) for different 
publishing channels.

Print images
PSD and TIFF are common image formats for print often set at 300dpi (dots per 
square inch) and always CMYK. Resolution-less graphics such as graphs are used in 
Illustrator (AI) and EPS (Encapsulated Postscript) formats.

Web formats
JPG, GIF, PNG (bitmaps) and SVG (resolution-less) are common web formats for 
images. Bitmap formats are often set at 72 or 96 dpi and are RGB.

Print Web (XHTML)
.psd (cmyk, 300dpi) .png (rgb, 72dpi)

.tiff (cmyk, 300dpi) .jpg (rgb, 72dpi)

.jpg (cmyk, 300dpi) .jpg (rgb, 72dpi)

.ai .svg

.eps .svg

Image specifications
C O R E  E S S E N T I A L S

Adobe Illustrator software is capable 
of producing both AI, EPS and SVG 
formats. Most image editors like 
Photoshop and GIMP can produce all 
bitmap formats.

The major difference in using images 
between print and web is that web 
images are cropped to the borders 
of the frame whilst images placed in 
InDesign are often not. For a traditional 
DTP designer this presents an extra 
process whilst for web designers, this 
is common practice. Designers need 
to find a dual solution that suits them 
and preserve appropriate quality for all 
channels.

Embedding images
All images being exported in IDML 
must be embedded in the InDesign 
software. This converts the image to 
based64 code. It is this code that is 
reconverted into the original image. 
There is no manipulation of images. 

Print and web assets
For designers setting up a document 
for both the iXBRL and PDF formats, 
there are two solutions to address the 
management of differing image assets. 

One - Use two layers - one for web and 
one for print

Two - Use two folders and when it is time 
to change from one to the other, you 
can use the built-in swapping tool in the 
InDesign software.

Colour
It is advised that designers work in 
RGB first and convert to CMYK at 
an appropriate time when printable 
artwork is needed.
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Be careful of JPGs
JPGs (JPEG) can present certain issues 
as they can be saved/used in CMYK 
and RGB. Also, older versions of Adobe 
Photoshop software and other image 
editing programs present differences 
in ‘saving’ and ‘exporting’ to the jpg 
format.

A note on spreads
Large images used across a spread 
(two pages) need to be separated/split 
into single page usage.

Images and file size
Images should be cropped to the 
containing frame size, reduced to 72dpi 
and be RGB. They should be of file type 
- png, jpg or gif. 

Infographics
The recent history of the InDesign 
software has seen it increase its ability 
to create more complex infographics. 
We encourage designers to test 
such pages in their reports with our 
IDML>XHTML converter. If the results 
are not satisfactory because there are 
certain aspects we do not support 
then it is very easy to convert such 
graphics to SVG. The steps to take are;

1. Copy infographic to a blank InDesign 
document

2. Export infographic to EPS from the 
InDesign software

3. Open EPS withAdobe Illustrator 
software

4. Save Illustrator file to SVG
5. Place SVG in the InDesign software to 

replace infographic

You will need to make considerations 
on embedding the glyphs of any fonts 
used or convert text to outlines.

Multiple effects and images 
combined as a single image 
It is possible in the InDesign software 
to create very complex, composite 
images using a combination of bit 
maps, gradients and other effects. 
These are not easily converted. It 
is better to take composite images 
and export them from the InDesign 
software to create a single image 
such as JPG, PNG and replace the 
composite image in the InDesign 
software with that image.
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Workiva Integration Plugin 
C O R E  E S S E N T I A L S

Workiva Integration 
Plugin for InDesign 
Software
The purpose of this plugin is to support 
the conversion of InDesign to XHTML. 
Initial content should be created in 
the Workiva platform and exported as 
ICML, then imported to InDesign. The 
Workiva Integration Plugin for InDesign 
Software should be used as designers 
are preparing the artwork, and before 
bringing the content back into the 
Workiva platform as an IDML file.

The plugin is provided so that 
designers have a validation tool that 
identifies issues within an InDesign 
document that would corrupt or 
are otherwise not appropriate for 
conversion into XHTML. This plugin 
is easy to import in both Mac and 
PC versions of InDesign and writes 
a report at the click of a button. In 
all cases the things we point-out are 
XHTML conditional and not a specific 
condition of the Workiva platform.

The Stop/Start button
If you want to monitor the ICML, use 
the start and stop buttons. You can 
hit start when the ICML is initially 
imported, or you can wait till later in 
the process. This is optional.

Import ICML
Looks at your desktop to find the file 
exported from the Workiva platform.

Export IDML
Exports IDML from the InDesign file to 
your desktop.

Ungroup
All items should be ungrouped. This 
helps to ungroup all grouped items 
existing in the InDesign file in one click.

Validate
Pressing this button produces a log 
file showing warnings based around 
converting this document from IDML 
to XHTML. This log file can be found 
in the same folder of the IDML export. 
This should be reviewed before every 
import into the Workiva platform.

Validation list
The validation list will let you know 
if something needs to be updated, 
or will include some best practice 
informational items. 
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Workiva Integration Plugin 
C O R E  E S S E N T I A L S
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ICML
C O R E  E S S E N T I A L S

ICML (InCopy Markup Language) is an 
official format of the InDesign software 
and is used for importing and exporting 
structured content for InDesign. It is 
a linked file to InDesign and as such 
the content of an ICML file cannot be 
edited within the InDesign software 
until a user breaks the link. This is the 
foundation of data assurance that 
Workiva offers to its customers using 
InDesign software with the Workiva 
platform. 

ICML import best 
practice

Check all content is styled
Before you pull your ICML from the 
Workiva platform, make sure that all 
content has a style attributed to it. 
The default setting in the Workiva 
platform is ‘Normal’ and this style is 
converted to Bodytext on export via 
ICML. An easy way to identify ‘Normal’ 
is to change its colour to a contrasting 
colour for easy spotting eg bright pink. 

Import early
We recommend importing fairly early 
in the reporting process. Subsequent 
timings of ICML pulls should be 
discussed between designer and 
client.

Import a quantity of ICMLs 
before changing attributes
One ICML represents one outline item 
in the Workiva platform and this ICML 
only imports the styles associated with 
that outline (section). 

It is recommended that designers 
import a good quantity of ICMLs into 
the InDesign software before they 
start altering style attributes. It is good 
idea to see all styles being used before 
making any changes. 

ICML export
When you are ready File>Save 
As>InDesign (.icml). You will then be 
prompted to select:

Entire Document
Current Section
Select Sections 

ICMLs are exported within a folder 
structure that represents the Workiva 
platform outline for easy identification.

Place ICMLs
In your InDesign document, go to 
File>Place and navigate to your ICML 
file. Once placed, the ICML can fill one 
or multiple linked text frames. 

Maintain the links
For data assurance and so that you 
don’t need to worry about versions or 
checking of content, make sure you 
don’t break the links of your ICMLs. 

Update the links
With subsequent ICMLS, just update 
the links in the Links panel and the 
new updated copy will flow through to 
the InDesign software. All your design 
values will remain in place.

Style changes
Changes to style attributes in the 
InDesign software will remain even 
after further ICMLs imported even 
though the style remains as before in 
the Workiva platform. So changing a 
style attribute in the Workiva platform 
will not update the corresponding style 
in the InDesign software.

ICML milestones
When you have decided with your 
client dates for ICML imports to the 
InDesign software, it is a good idea 
to create a milestone in the Workiva 
platform. This means you can track 
content changes between the 
subsequent ICML pulls by creating a 
blackline.

Towards the end of the project, we 
advise doing one whole ICML pull of 
the whole document to absolutely 
make sure every ICML is the current 
one.
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IDML
C O R E  E S S E N T I A L S

IDML export best practice

Export early and often
We recommend you export your IDML package early in your reporting process and 
you do this often. We recommend this because:

• You become familiar with the process to save stress later on close to filing

• You can check your design by opening it in the browser - does it look as intended?

• You can check your design in the online viewer - how does it look?

• Check early so you have time to tweak your design if necessary.

The InDesign package 

When first uploading IDML it is always best to create a package that includes the 
fonts. It will also show you over set text and other useful information about your file. 
Subsequent IDML can be exported with Apple E or Ctrl E and added to the original 
package. The Workiva platform only needs IDML and the fonts being uploaded to 
create XHTML

Discrepancy report
When converting IDML>XHTML, an additional file now sits along your XHTML 
file with the appendage of ‘report’ in the name. This file gives you information 
about your conversion and will highlight issues if they are present. Designers are 
encouraged to view this report after conversion.

IDML checklist
1. Save a copy of your master document first and use this copy to prepare for 

IDML export

2. Ungroup all InDesign grouped items.

3. Unlink all ICML files. This can be done in the links panel.

4. Split all connected text frames using the split story script in InDesign 
scripts pallet.

5. Remove any hidden layers or layers used for admin purposes.

6. All images to be placed at 72 or 144 dpi, RGB and cropped to the image 
frame. This will reduce the file size dramatically.

7. Use SVG only for resolution-less vector graphics, not .eps or .ai files.

8. Make sure there is no overmatter.

9. Make sure tabs or overrides have not been used.

10. When uploading IDML it is best to create an InDesign package so you can 
upload the fonts as well. You do not need to upload the .INDD file. You only 
need the IDML file and the fonts as a single zip file.
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File size
C O R E  E S S E N T I A L S

Many regulators are now stating a file size limit of 100 MB max. 

How do you stop a filing or download nightmare? How can you reduce the size of 
your report? Read on for tips for designers can use to optimise their file size.

For the designer in InDesign
Here are things the designer needs to do to reduce the final file size in Adobe 
InDesign software:

• Avoid empty paragraphs to achieve extra space in your document.

• Make sure all content has a style name attached.

• Make sure you crop all your images to the correct size, 100% and RGB

• Review your font embedding in SVGs, or make sure you are using common web 
fonts, or just outline your text.

• Review your SVGs carefully, and make sure you are using the optimal points to 
create a shape. We were able to reduce a world map SVG from 5mb to 200k by 
optimising the number of points it used in Adobe Illustrator software without 
creating any visual difference.

• Think carefully if all of your images are necessary.

• Make sure you have reduced your images to 72 dpi—the resolution for websites.

• Exporting as IDML and re-importing into the InDesign software at the end of 
your process can cut down the file size as it can clear out unnecessary code and 
get rid of third party plugins.

IDML export is a file size detox, but here are some other things you can do before 
exporting:

• Remove any unused objects

• Delete unused styles

• Delete anything left on paste boards or any extra master pages

The XHTML code the Workiva platform produces is clean and optimised, which 
helps with file size and download speed. Essentially, everything not necessary is 
removed. Clients are advised to check with their filing regulator as to what the filing 
size limit is exactly in that jurisdiction.

Find out your file size 
limit early and check 

that you are staying 
within this limit
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Extra Essentials
Shapes
Please be aware that we do not support all 
aspects of shapes. It is best to test aspects of 
your artwork so that the results can be assessed. 
Shapes can always be easily converted to SVG 
by exporting them from the InDesign software 
to Adobe Illustrator software and saving to SVG 
format from there. Then replace the shapes in 
the InDesign software with the SVG images. 

It is best to use a placed SVG instead of multiple 
repeated InDesign shapes as this will reduce the 
file size significantly. 
Be careful of copy and pasting assets within 
the InDesign software. It's always best to 'place' 
assets afresh each time even if they are the same 
asset.

Track changes
If there is non- Workiva content in the InDesign 
file, please ensure that all track changes are 
committed if being used.

Third party plugins
Please ensure these are removed or that the use 
of them does not interfere with Workiva's IDML 
to XHTML converter.

Colours
Avoid colours too close. Gradients of colours 
from one to another must be avoided as at 
present this cannot be converted into XHTML.

Spreads
XHTML renders a page at a time so be careful 
with spreads. PDFs can be set to spreads to view 
but this is not the case with XHTML. You can 
add an XBRL viewer with your report and with 
input from your web team, you could add spread 
capability. This however is not available open 
source.

Margins
Mirrored margins have no place in a digital 
medium and are a ‘print only’ feature.

Tabs
Tabs to not exist in XHTML. Tabs must not be 
used for alignment when converting to XHTML.

Columns
ICML exports in galley format. This is a single 
measure, continuous column. It is placed in 
columns in the InDesign software. ICML does not 
export multiple columns. 
In the Workiva platform, you can have a layout of 
up to 7 columns. However, for the ICML export 
to the InDesign software, column layout is not 
essential in the platform as the export sends 

content in galley (one column) format regardless 
of set up in Workiva. The designer takes the 
content and populates the columns in the 
InDesign software. The design from the InDesign 
document will create the XHTML, not the design 
in the Workiva platform.

Alien content
For data assurance, the main report content 
is created in the Workiva platform and this 
remains linked to the InDesign software where 
the designer can design without accidentally 
adjusting the content. Workiva is the master 
document here. However not all content has to 
be in the Workiva platform. So when would extra 
content be added in the InDesign software?

Picture captions 
If design is taking place in the InDesign software, 
images do not need to be added to the Workiva 
platform. Designers can image captions as 
necessary. These must be styled and are not 
effected on subsequent ICML imports.

Headers and footers
These do not export from the Workiva platform 
so these need to be created with InDesign 
master pages. 

Tracking and kerning
The InDesign software renders only once, so 
what you see on screen is the exact placement 
of content. On the web, this is different. The 
web renders every time you launch that page 
so designers must be aware of the limitations 
of the web. Justified text for example can have 
different line endings depending on zoom or type 
of browser being used. 

Typesetting
Typesetting takes place in the Workiva platform 
not in the InDesign software. In the Workiva 
platform, do not use a soft return. A soft return 
is when you press Shift Enter. This creates a 
line break rather than a paragraph break. You 
can see your soft and hard returns by pressing 
the Show/Hide non printing characters icon on 
your top ribbon. If words are not to be broken 
(like in a name) use a non-breaking space 
in between. Go to Insert>Symbol>Special 
Characters>Nonbreaking Space. 
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Glossary 
Definition of symbols

InDesign Compatible
These are features of InDesign 
software that are compatible 
with IDML> XHTML export

Avoid
These are features of InDesign 
software that are not compatible 
with IDML> XHTML export

Warning
These are features will need careful 
consideration or application if to be 
rendered in XHTML

Feature information
These are just InDesign features that 
have no bearing on XHTML

O F  X H T M L  A N D  I N D E S I G N  C O M P A T I B I L I T Y

Please note that common shortcuts have been added but these may vary due to platform and version of the InDesign software. Shortcuts mentioned 
in this guide are for Macs.
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Compatible Avoid Warning Info

The Widget

A
Align
Window > Object & Layout > Align 
This tool can align text boxes or images to left, 
right, horizontally and space items evenly.

Alignment
Alignment as a paragraph style - justified, 
centre, left or right.

Align to page alignment
This feature is not supported in the XHTML 
conversion process.

Anchoring
This is where something is attached to another 
object (i.e. a caption is anchored to the image). 
Move the image and the caption will follow 
automatically except for table cells. Please 
do not use anchored images within text. 
Placed images in table cells are automatically 
anchored and we do support that feature.

Please do not place grouped items in table 
cells. These cannot be rendered.

Anchor Point
Tools Panel > Anchor Point Tool

Gives control over the path of a stroke or shape 
to manually alter its direction or curves.

Asset Links
Window > Links 
In the InDesign software, images are linked 
from the desktop. For IDML these images will 
need to be embedded. To do this right click the 
image in the Links Panel and click on Embed 
Link. The image is now a permanent feature 
of the file. Just to note embedded images is a 
requirement of ESEF and should be in base64.

Arrange
Window > Arrange

This allows you to order a selected item to the 
back or front of your document within the same 
layer. This is referred to as the z-index in web 
terminology.

B
Baseline Grid
Baseline grid is not supported in XHTML. If using 
a baseline grid designers need to push their 
paragraph styles as far as possible to replicate 
the effect. 

Baseline Shift
Baseline is an invisible line where letters sit. 
Baseline shift moves text up or down from the 
baseline. Select text then Option/Shift up or 
down arrow. 

Bleed
Bleed is a print function. The images which 
are required to go to the edge need to actually 
go over the edge and then be cropped by the 
printer. Our convertor will also crop.

A
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Book
File > New > Book

The InDesign book format is a collection of 
InDesign documents that share the same 
format and can be numbered sequentially. A 
book can have multiple documents. We do not 
support the InDesign book format. The XBRL 
profiler stitches together multiple conversions. 

Bodytext
The only Paragraph style that gets updated 
each time with ICML is called 'Bodytext'. 
Precisely spelled this way. This is because it is 
used to replace the 'Normal' default style. All 
other style names from the Workiva platform 
will NOT update the InDesign styles once they 
are there.

C
Clipping mask
This is a shape (container) and an image 
(filling). We only support a single object, image 
or shape within the clipping mask. We do not 
support grouped items having a clipping mask 
applied to them.

Comments
Clients/designers should use the Comment 
Function in the Workiva platform and not 
leave comments in the text. At this moment 
there is no way to pass comments to the 
InDesign software.

Colours
Workiva uses RGB colours for web usage. For 
IDML export RGB colours only. 

Consider all screen 
resolutions. Not enough 
colour contrast limits web 
accessibility for some users

Character Styles
Character styles are exported via ICML and 
we support character styles in IDML> XHTML 
conversion.

Columns
The Workiva platform can support multiple 
column layout up to seven of like width. 
However, the content from ICML export is 
only one column by default (galley). This 
can populate many columns in the InDesign 
software. The InDesign layout will prevail in 
the XHTML.

Corners (Rounded)
Object > Corner Options

This will change the corner size and shape. 
These are called Squarcles. We support 
rounded corners in IDML>XHTML.

B C
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D
Drop Cap
This typographic effect is used a great deal 
in print and not so much in XHTML. The drop 
cap can be across multiple lines with one or 
multiple characters at the start of a paragraph. 
We have limited support for drop caps so 
please test thoroughly. The workaround 
advised is to add an image for the drop cap.

Drop Shadow
This effect is not supported in IDML and 
should be avoided.

Descender
A descender letter is a letter that falls under 
the baseline for example ‘y’. The tail of ‘y’ is a 
descender.

E
Effects
Object > Effects 
Only transparency is supported. Gradients are 
not supported.

Subtle variants don’t show on 
all screens

Ellipse Tool 
Use this tool to create oval (ellipsical) or circle 
(by holding down Shift) which are then ready 
for colour and/or text. 

Ellipse Frame Tool 
This is used for creating a frame to place an 
image into.
Export
Export to IDML format for XHTML conversion.

F
Fonts
The first thing to check is that your client has 
web usage rights to all the fonts used in the 
report. It is advised that the licensing agreement 
contains a web font license. Any font (TTF or 
OTF) can be used because the IDML>XHTML 
will consume and convert uploaded fonts. 
Please make sure they are included in the IDML 
export.

Wingdings or Zapf Dingbats should be used with 
care and tested in XHTML.

Facing Pages
Created in the InDesign software for print 
layouts. Pages in the XHTML output will be 
displayed in order but in single pages only. 
The iXBRL reader can be developed to display 
spreads however.

Fill
Shortcut X 
For this tool you set a colour and fill a frame.

For ESEF, fonts need to be 
embedded in the file as base64 
code.

Consider open source fonts for 
licensing and web suitability
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G
Glyphs
Window > Type & Tables > Glyph

A glyph is a letter/symbol making up a font. 
This palette will show all the available glyphs 
in the selected font. IDML will convert these 
symbols to code (e.g. @ = &#64;).

Gap Tool
Shortcut U

This changes the size of objects but maintains 
the gap between them.

Gradients
A gradient is a flowing blend between one 
colour and another or from one tint to another 
tint of the same colour. We cannot accurately 
convert InDesign gradients to XHTML.

Gradient Feather Tool
Shift G

This tool allows you to fade an object/shape 
from opaque to transparent. Point to be aware 
of is that subtle gradients do not show up on 
the web due to screen resolution.

Gradient Swatch Tool
Shortcut G

You can adjust your gradient here.

Grids - Baseline Grid
View > Extras > Show Baseline Grid 
The baseline grid is a framework that is used to 
align text. It is only shown in the printable area. 
It is not supported in IDML>XHTML.

Grids - Document Grid
View > Extras > Show Document Grid

This grid extends to the non-printable area 
around the page (the pasteboard) so that 
attributes can be stored for later use.

Group
Object > Group / Ungroup

The Group tool collects any item in the 
InDesign software and maintains XY 
coordinates when moving or rotating the 
group. XHTML does not support grouped 
items therefore you are required to ungroup all 
grouped items before conversion. 

Guides
Layout > Create Guides

You can manually drag guides from the ruler 
bar. This is used to create individual guides 
rather than the document grid. 

G G
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H
Hand Tool
Shortcut H

This tool is used to grab the actual document 
and move around in your screen view between 
the pages or spreads.

Hyphenate
Located in the Paragraph panel

If you tick the hyphenate option in a paragraph 
style, it allows words to break at the end of 
the line across to the new line automatically. 
This is an InDesign function and is partially 
supported in XHTML conversion.

In certain languages the management of 
hyphenation is very important. It is advised 
that designers who are using those languages 
test thoroughly the IDML>XHTML convertor to 
make sure they get the effects that they want.

Hierarchical Styles
We support inheritancy (based on) in style 
pallets, paragraph, character and cell.

Info
Window > Info

Highlight text and then click window>info and 
it displays how many paragraphs, lines, words 
and characters. This is a good tool for clients 
to know how many words they need to fill a 
text area.

Intent
File > New Document > Intent

This is where you can set the intent of the 
document (e.g. print, web or mobile). This 
creates page sizes suitable for the use or 
platform. On newer versions web and mobile 
are tabs where you can set the size. For  ESEF, 
the report is shown in a pdf style format so the 
web or mobile page setup is not necessary. 

I K
Kerning
Character palette or Command T

This is where you can increase or decrease the 
space between individual characters. Kerning 
can be set in the InDesign software only. There 
is a word spacing function in the platform but 
this is not exported in ICML. It is unclear as 
yet as to how far we will go to support kerning 
in IDML to XHTML. It is certain that we will 
support it as part of a style and is certain that 
we will not support it as an override. This means 
that designers who break the ICML link to use 
kerning techniques for widow management 
cannot do this anymore. 
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L
Leading/Line Feed
Leading is the space vertically between lines 
of type. It is measured from one baseline to 
the next. The InDesign default is 120%. You 
can change leading in the InDesign paragraph 
styles panel. 

Layers 
Window > Layers

Layers help organise a document. The visibility 
of each layer can be turned on or off. You can 
lock a layer to prevent items on that layer from 
being selected. It is often used by designers 
when coming up with design visuals for clients. 
Layers can also be used for comments. Delete 
all hidden layers and layers used for admin 
purposes. 

Please remove hidden layers 
before conversion to XHTML

Line Numbers
Some designers add line numbers as a 
development feature in the InDesign software 
often on a hidden layer. Designers should 
delete these before IDML creation.

Line Tool
Shortcut \

This creates a single line. It can be edited in 
the Stroke panel (window>stroke) i.e. weight, 
colour, etc.

Holding down the shift key keeps the line 
vertical or horizontal.

Links (Assets)
Window > Links
In the InDesign software,  images are linked 
from the desktop folder. For IDML these 
images will need to be embedded. To do this 
right click the image in the link panel and click 
on Embed Link. The image is now a permanent 
feature of the file. 

For ESEF, fonts need to be 
embedded in the file as base64 
code.

Liquid Layout 
Window > Interactive > Liquid Layout

This allows for different page sizes across your 
document and must not be used for IDML 
export.

Lists
The InDesign software only supports 6 levels 
of lists whereas the Workiva platform supports 
more. 

Many designers are moving away from 
encapsulated lists. If you need to use more 
than 6 levels, just create the right number of 
paragraph styles with the appropriate indent 
and space above/below. 

Lock 
Object > Lock

This locks elements so that you cannot 
accidentally move them. Designers must 
unlock before export.

L L
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M
Margins
Layout > Margins and Columns

With a new document use this function 
on your master page and this will be set 
throughout the document. Click on each page 
if you want to adjust the pages later on.

Markers
Type > Insert Special Character > Markers (Page 
numbering)

Here you need to create a text frame then 
click on markers. If this is done on the master 
document, it will appear on all pages that 
have been created from the master page. We 
support page numbers but do not support text 
variables. 

Master Pages 
Window > Pages

Master pages are simply templates set up with 
common attributes e.g. headers and footers, 
page numbering, logo etc. You can create more 
masters (e.g. left and right-hand templates for 
spreads). You drag the master page into the 
Page panel to place those items.

Measure Tool
Shortcut K

This tool measures between two points and 
appears in the information bar. 

N
Negative indents
Negative indents are not supported in XHTML.

Nested Styles
Far right of application bar > Drop Caps and Nested 
styles 

A nested style is a style within a paragraph 
style. It will effectively override the paragraph 
style. This is not supported together with other 
style hierarchy.

Notes
Type > Notes

Here you can leave notes or comments for 
review.

Numbering & Section Options
Layout > Numbering & Section Options

When creating a large report, this helps with 
navigation. 

The sections are shown in the thumbnails in 
the pages panel. We support automated page 
numbering.

O
Object 
Top menu > Object 

An object in the InDesign software is anything 
that can be edited ie text frame or image. 
With this drop down menu you can send the 
object to back or front, add effects like a drop 
shadow or transparency. We support limited 
attributes of object styles. Border, background 
and colour.

Observed regions
The Workiva platform uses the concept of 
observed regions for a number of reasons 
including XBRL tagging. This is reflected in 
the InDesign software using the tagging panel 
and can be seen as multi-coloured squared 
brackets around the ICML content. These 
brackets do not affect the design in any way. 

When splitting a number of text frames, 
please do not split across an observed region, 
denoted by the square brackets shown below.

[open/.… split..../closed] 
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Optical Margin Alignment 
Top menu > Window > Type & Tables > Story

This tool will shift characters like speech 
marks to create a cleaner line. See example 
below. We do not support this. 

Overprint
View > Overprint Preview

Spot colours are used when colour accuracy 
is critical. This preview will show you more 
accurately how the colours will actually look 
in print. We do not support spot colours. They 
can be changed in the InDesign software in 
the colour palette affecting the linked ICMLs.

Optical Margin example

P
Package
File > Package

This is used when sending the InDesign file 
to somebody else or good practice for your 
own information. This brings all the assets 
together into one folder.

Page Numbering
In the pages panel, double click master 
pages. Add a text frame large enough for your 
biggest number. Add a text frame to left and 
right master pages if applicable. Add text, 
if required, for example ‘page’ then position 
where you want the number to go then 

Type > Insert Special Character > Markers > 
Current Page Number

By default, the numbering is 1,2,3 etc. 

For different numbering - Layout > Numbering 
& Section Options

Pages Panel 
Window > Pages

You can navigate through your pages using 
the Pages Panel. Here you can add more 
pages, delete or duplicate.

Page Tool 
Shift P

This just changes the page size of one page 
in your document. It will not affect the other 
pages. 

Paragraph Panel
Window > Type & Tables > Paragraph

This is used for individual paragraphs rather 
than using paragraph styles. We do not 
support overrides.

Paragraph Formatting Controls
Top Application Bar 

This contains lots of style controls. Access by 
clicking on the ‘A’ which is top left. We do not 
support overrides.

Paste/paste into
Edit > Paste / Paste in Place

Please place all images. Do not cut and place 
multiples of an image. This includes pasting 
into shapes.

O P
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Pasteboard
View > Entire Pasteboard

The Pasteboard is the whole area including the 
area for non-printed content.

Pen Tool 
Shortcut P

This creates custom lines.

Pencil Tool
Shortcut N

This creates lines as the pen tool but with more 
flexibility.

Place
File > Place

Images should always be placed rather than 
pasted. Images should be placed at 100% ideally 
for optimal file size. Images should also be fitted 
to the frame that they occupy. In other words, 
images should be cropped to the frame.

Plugins
All plugins should be disconnected before 
IDML export.

Polygon Tool
Tools Panel > Right Click > Polygon

This is supported. Please be careful about 
placing grouped items within a polygon as this 
will not be converted.

Preflight 
Window > Output > Preflight

Preflight checks for errors before exporting 
and packaging in a zip file - things like missing 
files or fonts, low-resolution images and text 
overmatter.

Profiles
Edit > Assign Profiles

Here you can alter the colours of your 
document without converting colours (e.g. RGB 
to CMYK). 

Clear all pasteboard items for 
a quicker conversion 

P P R
Rectangle Tool
Shortcut M

This creates a rectangle frame ready for text/
colour etc. Holding down the shift key creates 
a square. We support this as a text or image 
frame.

Relink
Window > Links or bottom of links panel

Images etc that have been renamed/moved 
can create an error and it is here where you can 
relink.

Revert
File > Revert

This goes back to the previous version of 
your document. Make sure that you have the 
current ICML.

Rotate Spread
View > Rotate Spread

This is only for working on your document. It 
does not alter print or IDML export.

Rotate Content
We support rotated content

Rulers
View > Show Rulers

Rulers can be dragged across from top down or 
left across.
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Scale Tool 
Shortcut S

Grab the frame handle and resize.

Scissors Tool
Shortcut C

This cuts a frame or path.

Screen Mode 
View > Screen Mode or W

This switches between normal editing mode 
and preview.

Separations
Window > Output > Separations Preview

This shows all the colours which are being 
used and can check when one colour is 
being printed over another (e.g. knockout or 
overprint). This is an InDesign software only 
feature.

Shear Tool
Shortcut O/ Object > Transform

This changes shapes to create a more 3D 
effect by slanting an object. This is supported.

Slug
File > New Document > Bleed and Slug

Slug is a function not often used. It is used for 
leaving instructions outside the printed area 
and outside the Bleed area. 

Split Story Script
For IDML export, do not split a bulleted item 
across text frames. The list can be in multiple 
frames but not an individual bullet.

Smooth Tool
Tools Panel > Under Pencil Tool drop-down menu

This removes/simplifies anchor points on 
shapes. When placing many shapes in a 
document, designers need to be aware of 
the number of points in a shape. It is best to 
optimise these for successful conversion and 
optimal file size.

Spreads
Please note that for IDML>XHTML, we process 
pages, page by page. iXBRL readers can display 
spreads although this will need some web 
development from your team. Please note that 
spreads over three pages cannot be used.

Stroke
Window > Stroke

With this panel, the appearance of lines can be 
altered.

Styles
Window > Styles

This should be used for setting Paragraph, 
Character and Cell. This is a time saver and 

should be used consistently across your 
whole document. 

Please note that only the border and 
background of object styles are supported.

SVG
ESMA doesn't allow the <object> tag or <svg> 
tag so inline presentation is not allowed as we 
can't read the fonts.

To ensure that the SVG file appears correctly, 
if embedded in a web page:

1. open the SVG file in an illustration 
program

2. convert all font characters to outline 
paths

3. re-export the SVG file and embed that 
file

Alternatively, you can use web fonts to ensure 
that the necessary fonts are available on the 
web server.

Swatches
Window > Colour > Swatches

This panel is your library of colours or tints. 
Once a colour is applied, like paragraph styles, 
edits made to a colour choice will change all 
instances of that colour across the document. 

S S
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T
Table Measurements
The Workiva platform measures tables in pixels. 
The InDesign software measures by default in 
points, but can also do mm, picas and other 
forms of measurements. To set the correct 
body text width in InDesign for your desired 
table width please set In Design units to pixels 
and therefore you have parity with the platform.

Table 
Table tab in the top menu.

Here there are the usual features of the number 
of columns, rows including height and width. 
We do not support table overrides in any form 
for XHTML export.

Table Cells
Avoid putting a text frame within a table cell. 
We do not support this. 

Text colour - inherited
We do not support inherited text colours. This 
is a feature of the InDesign software often 
using rule above/below. Please specify an 
actual colour from the colour palette.

Text frames
Text within a NON-rectangular text frame will 
not be supported. Please only use rectangular 
text frames.

Transform
Object > Transform

Here you can flip horizontally or vertically, 
scale, rotate or shear. Shear is when you slant 
an object. If an image converts incorrectly 
please check any transform done in InDesign.

Type Tool 
Shortcut T

This tool creates a text frame

Use the Type Tool to create a text frame (just 
click and drag) for inserting text or click once 
on an existing frame or shape to transform it 
into a text frame. 

Type on a Path Tool
Shift T

First you need to use the Pen Tool to create a 
path. Then you click the Type of Path Tool, go 
over to your path and click just once where 
you want the text to start. You then type and 
your letters will follow the path.

T T
Tabs
Tabs must not be used. Ever! 

Text Threads
View > Extras > Show Text Threads

Text threads show the text frames that are 
linked together to create one single flow of 
text. You can link a text frame by clicking on the 
square in the bottom right corner of the text 
box and then clicking again in the following 
text frame. All linked text frames must be split 
before conversion.

Text Wrap 
Window > Text Wrap

This panel wraps text around images or shapes. 
We do not support this. 

Tracking
Windows > Type and Tables > Character

This reduces or increases the spaces between 
characters in a sequence of text. This tracks 
everything back and adjusts the whitespace 
proportionally back. This can be done as part 
of character and paragraph but cannot be 
accepted as an override.

Important - Tabs do not exist 
on the web!
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Units & Increments
Preferences > Units & Increments

You can set your preferences here for 
measurements. Pixels are usually used for web 
design so this should be selected for parity 
with the Workiva platform.

V
Variables
Type > Text Variables

Text variables can be used within text and text 
frames. These changes are dependent on a 
number of factors. Pagination, section, dates, 
running headers are some ways in which they 
are used.

We will be discussing whether we will support 
some of these items in certain circumstances.

W
Wingdings
Not all browsers understand Wingdings, 
Webdings and Zapf Dingbats. Best to avoid. 
There is limited unicode support. 

Workspace
 Window > Workspace

Workspace controls what panels you have 
available on your screen. You can click back to 
‘Essentials’ to tidy up your workspace.
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XML 
File > Import XML

XML or Extensible Markup Language is a 
toolset for data. The InDesign software can 
work with XML files. Using this structure 
you can tag the content of your InDesign file 
and use this structured data for use in other 
applications.

XML tags can be mapped to styles in order to 
facilitate the formatting of this content. There 
are systems that work in this way.

The ICML exporter uses the InDesign 
software’s built-in XML structure to facilitate 
the passing of observed regions from the 
Workiva platform to ICML, to be retained in 
the InDesign software, and exported via IDML 
for conversion to XHTML. These InDesign tags 
are used to populate XBRL at conversion time. 

Z
Zapf Dingbats
Not all browsers understand Zapf Dingbats. 
Best to avoid.

Zoom Browser
Beware that some browsers complete values 
based on zoom levels. E.g. line rule weights 
may look different based on browser and scale 
used.

Zoom Tool
Shortcut Z

This tool does exactly as it says and it’s also 
great for moving around a spread.
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Q&A
Document setup
Question: Can I have my report in a 
landscape format?
Answer: Yes! You can choose the layout in document 
properties and we do support landscape in xHTML. 
Much better for screens.

Question: How does the file set up work? 
Do you take last years InDesign files and 
convert them in the Workiva platform?
Answer: If you have last year’s InDesign file, the easiest 
way is to export as a Microsoft Word file from the 
InDesign software. Then import this Word file into the 
Workiva platform. Check that all the styles have been 
applied. Note the maximum file size to upload to the 
Workiva platform is 250mb.

Question: Is there a limit on section sizes 
that the document is broken into?
Answer: It is best practice that the outline reflects the 
menu/submenu of your report. This makes it easier for 
your designer to navigate through the ICMLs. Name 
your sections to reflect its content.

Table setup
Question: My table(s) is/are missing!
• If you are using localisation in the InDesign software 

please report this to your CSM. This may affect 
tables.

• Check the style wrapping around the table in  the 
InDesign software. Default in our ICML export is 
Bodytext. It's possible that other styles/parameters 
could cause unforeseen effects.

• Make sure your tables are in fact tables, not tabbed 
content e.g. 'Table of Contents' material.

Question: How about table styles?
Answer: The Workiva platform exports one table 
style in the ICML and this is applied to all tables. 
Adjustments can be made universally across the 
document via the Table Styles in  the InDesign 
software .

Question: I want to adjust a cell style for one 
table in my report but not affect the other 
tables, what should I do?
Answer: If you want to isolate a single table, you do 
this by adding a light background colour not used 
elsewhere in the report. This will make this table visible 
to the designer who can then edit those unique cell 
style as the unique background tint will generate 
unique styles. 

Style guides
Question: I have applied styles to all the 
document in Workiva but I still get auto 
generated styles in the ICML export. Why is 
this?
Answer: The Workiva platform does not have bulleted 
styles in the custom styles pallet. Bullets are created 
by touching the ribbon. So all bulleted lists will create 
an auto generated style. It is a good idea to still create 
and apply a ‘bullet’ list style in the Workiva platform 
and then touch the ribbon. From ICML, the designer 
can easily see the bullet style, whilst ignoring the auto-
generated numbers.

Question: What are the coloured brackets 
around the figures in the financial section?
Answer: These coloured brackets do not affect the 
design. They are there as placeholders for the XBRL 
and observed regions when you export to IDML. 

Question: Two rule weights should appear 
but only one is showing in the XHTML
Answer: This is the resolution of the page in the 
browser. Use browser zoom to see more clarity on 
rule weights. Designers need to be aware of this when 
setting rule weights. Rule weights below 1px can suffer 
from resolution issues in many browsers.
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Colour management
Question: We will need to print the 
document so how do the colours and 
final output work? What colours does the 
Workiva platform use and how can I achieve 
my CMYK print doc and my RGB PDF?
Answer:
By default, the Workiva platform uses RGB colours 
and it is best practice for designers to keep to the 
RGB colour format until they need to create artwork 
for printing purposes. XHTML output only uses RGB 
colours. For designers who are concerned about 
any delay in creating a printable document in CMYK, 
setting up the colour palette in another document 
should be considered ready to be imported at the time 
of need.

Question: Can I add a space to a style name?
Answer: No! Style names must not contain spaces. 
This is a CSS standard. You can replace the space with 
an underscore to help with readability if required or 
use CamelCase.

Question: Should the style sheets be set up 
in Workiva or InDesign?
Answer: If you have an existing InDesign file, you might 
want to import these styles into Workiva. You need to 
follow three steps to guarantee a smooth import. 
You can also set up your styles in the Workiva platform 
and import them via ICML to the InDesign software. 

Question: Do all files link to the same style 
sheets and does everything need to be on a 
style sheet? 
Answer: All sections in one Workiva file link to 
one style sheet. You can copy style sheets from 
one document in the Workiva platform to another. 
Multiple documents can be imported into the 
InDesign software where the style attributes can be 
manipulated.

Question: Can you do manual overrides in 
the Workiva platform and do they transfer 
back into the InDesign software properly? 
Answer: It is best practice to not use manual overrides 
as ultimately these will not convert into XHTML. If 
you need to use an override, use a style close to it, for 
example Bodytext but then clicking on the text colour 
blue. The style will flow through ICML to the InDesign 
software as an override (ie an auto-generated style) 
but designers can easily find the style as it will begin 
with the style that was applied ie in this case Bodytext. 
Designers can then change the style characteristics 
from there on.

Question: Can new styles be added once the 
document is in Workiva?
Answer: New styles can be added at any time and will 
be added to the InDesign software via ICML when that 
style has been used.
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Question: What fonts are supported in the 
Workiva platform?
Answer: Here are the fonts currently supported.
Please contact Support if you would like to add these 
or other fonts to your account.

Question: Can my font used in the InDesign 
software export correctly?
Answer: Yes it will, however, you need to make sure you 
have web usage rights. You need to check your licence. 
Many font rights are only for print. If in doubt, we 
recommend you use an open source font. Google open 
source fonts can be found here. 

Question: Can I use any fonts?
Answer: Wingdings, Webdings or Zapf Dingbats 
should be used with caution and checked in XHTML. 
Fonts being uploaded to the Workiva IDML>XHTML 
converter need to be TTF or OTF and must have 
permissions for use on the web owned by the client.

Question: If an IDML file has a font that is 
not in the Workiva platform, and this IDML 
is converted to XHTML, what can we expect 
from this file?
Answer: If the fonts are not in the Workiva platform, 
you will need to upload your fonts with the IDML files. 
Again check licensing across all fonts and weights. 

Typographic layout
Question: I have over-lapping text!
Answer: 
• Look at the text frames concerned carefully. Are they 

unlinked? Have they been split properly?

• Where they unlinked before they were split?

• Check for hidden content (overmatter) in your 
InDesign files shown as a red cross at the bottom 
right of a text frame.

• Pay attention to the InDesign package report. It will 
indicate over-set text on certain pages.

Question: Can highlighted text, 
strikethroughs or other inline effects export 
to the InDesign software?
Answer: They can but you need to set up a custom 
style and not use the ribbon for formatting. 

Question: Our designer has some extra 
pages that are not in the Workiva platform. 
What should we do here?
Answer: If the styling guidelines are followed correctly, 
this should be ok for IDML>XHTML conversion. 
Examples of this are pagination, image captions, 
header and footers etc.

Fonts
Question: My headings have got the wrong 
font weight!
Answer: 
• Did you upload your fonts?

• Make sure you have uploaded the correct typefaces 
by completing a package in the InDesign software.

• Make sure your fonts are TTF or OTF.

• Make sure your font is not corrupt. Try it out on 
another system.

Question: Can I use a font that is not in the 
Workiva platform?
Answer: Yes you can, as long as the client has a licence 
for that font for web usage. The font will need to be 
included in the IDML export for compliance with the 
ESEF mandate. The font used in charts will remain 
the same as in the Workiva platform as charts get 
exported as SVGs and cannot be edited in the InDesign 
software.

Question: Can I use the normal style in the 
Workiva platform?
Answer: It is best practice not to use the ‘normal’ style 
in the Workiva platform. The reason is that InDesign 
software can have issues with this default style so we 
recommend it is avoided. 

https://support.workiva.com/hc/en-us/articles/360035640072
https://fonts.google.com
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Question: Can justified text work in xHTML?
Answer: We do not recommend that justified text be 
used over a short measure (width of column). InDesign 
software has numerous controls for justified text. 
XHTML does not

Question: How do I add a paragraph break in 
the InDesign software?
Answer: You cannot add a paragraph break in the 
InDesign software. This needs to be done in Workiva. 
Any extra spacing must be achieved with Styles e.g. 
'SpaceBefore" or "SpaceAfter". To manipulate text 
in the InDesign software, use linked text frames to 
control spacing and placement. This means the design 
will stay in place with subsequent imports of ICML.

Question: Do headers and footers export in 
ICML?
Answer: Headers and footers do not export from the 
Workiva platform. Designers can create them in the 
master pages.

Question: What is the current status of 

Workiva footnotes and ICML-export? Is it 
correct that footnotes in the platform can 
be used and they export into a separate icml 
export file?
Answer: Footnotes from the Workiva platform export 
via ICML to a separate ICML file within the relevant 
outline folder. In the Workiva platform they are always 
in the bottom right. As they are separate in ICML 
export they can be placed anywhere in the InDesign 
software and data assurance is still relevant. 

Question: Last year our pagination changed 
quite dramatically at a late date, is it quite 
simple to reorder in the Workiva platf?
Answer: Pagination is done in the InDesign software. 
Headers and footer content do not transport via ICML. 
For last minute editing see The Designer’s workshop 
#4: advanced workflow.

Image specification
Question: My images look wrong or are 
missing!
Answer: 
• Check they are embedded, placed at 100%, fully 

cropped and 72 or 96dpi

• Check they are not flipped in some way.

• Check that the image is not using some sort of 
InDesign effect.

• Check that there are no secondary effects on top of 
the image e.g. radial gradient hotspot.

• Ensure images on the right-hand page, starting at the 
spine do not overlap the left-hand page at all, even 
by 0.0001 pt. This will result in the convertor thinking 
this is a left-hand page image only. 

Question: How about picture resolution for 
an ESEF filing?
Answer: For web viewing, 72dpi or 96dpi is standard.

https://event.on24.com/eventRegistration/EventLobbyServlet?target=reg20.jsp&referrer=https%3A%2F%2Fsandbox.wdesk.com%2F&eventid=2963641&sessionid=1&key=025D19479CFD8620C82EE6A514EF0139&regTag=2037576&V2=false&sourcepage=register
https://event.on24.com/eventRegistration/EventLobbyServlet?target=reg20.jsp&referrer=https%3A%2F%2Fsandbox.wdesk.com%2F&eventid=2963641&sessionid=1&key=025D19479CFD8620C82EE6A514EF0139&regTag=2037576&V2=false&sourcepage=register
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Question: How do the Adobe Illustrator 
files charts and images show in the Workiva 
platform? Are they a placeholder image, or 
are they removed entirely?
Answer: Images can be placed in Workiva as png/
jpg etc (not svg). They will be exported via ICML in an 
asset folder. When using the IDML process to create 
XHTML, images are not necessary in Workiva. They 
only serve as additional location support. Images come 
from the InDesign software to produce XHTML if the 
roundtrip is being used.

ICML
Question: I have been working in InDesign 
software for some time and I have just 
imported another ICML file. Colour square 
brackets have appeared which was not there 
before. What is this?
Answer: The coloured bracket is a placeholder for 
XBRL and does not alter any design attributes so just 
ignore it.

Question: I get loads of strange styles when I 
import ICML into the InDesign software?
Answer: Extra styles will be generated for these 
reasons:
• No style was applied in the Workiva platform

• A style was added but then altered with the ribbon 
eg bold or italic

• A bullet list was used

• Linked content

Question: When the file has been exported 
to the InDesign software, can we continue to 
make changes in the Workiva platform?
Answer: Yes! It’s a good idea to liaise with your design 
agency when they would like updated content from 
the platform. Once you send your designer your ICML 
export, they can continue the design process. When 
you resend the updated content again, all the design 
the designer has done, remains intact.

Question: Are there limitations with regards 
to the size of the ICML file that is sent to the 
designer?
Answer: Like most files, these should be limited to 
around 5mb. Very large text files can cause a memory 
outage in InDesign, partly because the InDesign 

software itself is very hungry on memory! If the 
InDesign software struggles with files up to 5mb, it 
might be prudent to check other processes going on 
(antivirus software for example running intermittently).

Question: How do I track when I last 
exported content to my design team?
Answer: We recommend here that you create a 
milestone in the Workiva platform each time you 
export to InDesign. You can then create a blackline 
between each milestone.

Question: Is there any limitation in the 
Workiva platform regarding the size of the 
ICML to be exported, or the IDML to be 
imported, or the final XHTML / PDF files to 
be published?
Answer: Different regulators have different file size 
limits so we advise checking in advance. For exporting 
to the Workiva platform from the InDesign software 
and vice versa, there is currently a 2-minute timeout 
limit. Files need to be uploaded within this timeframe.



41The Widget

IDML
Question: Is it possible to see the XHTML 
without the iXBRL tags?
Answer: Yes it is possible to see just the XHTML. If the 
standalone options does not appear in the account, 
contact your CSM to get this option enabled. You do 
not see the table style in Workiva. It is part of the ICML 
export.

Question: Related to the import from 
InDesign into Workiva, our annual report is 
4 columns which is handled by our designer 
due to its complexity. How will this work?
Answer: When we import an InDesign IDML file 
into Workiva, we do not import the content into the 
platform itself. We convert IDML to XHTML which 
can be downloaded and viewed in your browser. The 
conversion will be as close as possible to the InDesign 
layout as long as the guidelines are followed. Columns 
in InDesign are made up of a single story that flows 
through them. These columns are connected. In order 
to convert accurately, you need to use the split frame 
feature built into InDesign.

• Styles are named properly. For example, we saw 
a file that had a # as the end of a style name. This 
corrupted the InDesign file itself. Also watch out for 
a space at the end of a style names.

• Please check for non web compliant image assets.

• Please check for corrupted fonts.

• Please also make sure that your IDML is not 
corrupted. Try opening it in InDesign again and then 
re-exporting to IDML from that document itself.

• If you are behind a very strict firewall please make 
sure this is not causing any issues.

• Try your conversion at another time. It could just be 
case of network traffic.

• If you have complex shapes in InDesign over many 
pages, it may be worth converting these to SVG to 
simplify conversion.

• Remember unlink ICML first before splitting text 
frames.

Question: I uploaded my IDML file into 
Workiva but I can only download the XHTML. 
I cannot preview it in the IXBRL Viewer. Why 
is this? 
Answer: You need to go back to your client and request 
permission to access the XBRL. Not all users have 
access to all areas.

Question: Will the IDML export from 
InDesign change content in Workiva?
Answer: An imported IDML file into the platform will 
NOT change content. It is converted immediately in 
XHTML where you can open it in your browser. This file 
cannot be edited. It would have to be edited in Workiva 
then ICML to InDesign and then re-exported.

Question: My document fails on conversion!
Answer: 
• In addition to all the previous comments, please 

check the guidelines carefully.
• Make sure all ICML is unlinked.

• Any track changes are committed.

• All text frames are split.

• All items are ungrouped.

• No third party plugins are active or affect our 
processes.
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All information, content, and materials available in this document are 
for general informational purposes only. The content on this posting is 
provided "as is;" no representations are made that the content is error-
free or up to date. Designers should test their design in XHTML often 

and keep back up files at all times.

Adobe, Illustrator, InDesign and Photoshop are either registered trademarks or trademarks of Adobe in the United States and/or 
other countries. Microsoft and Word are trademarks of the Microsoft group of Companies. XBRL® and iXBRL™ are trademarks o 
XBRL International, Inc. All rights reserved. The XBRL™/® standards are open and freely licensed by way of the XBRL International 
License Agreement. Our use of these trademarks is permitted by XBRL International in accordance with the XBRL International 
Trademark Policy.
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