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All information, content, and materials available in this document are for general 
informational purposes only. The content on this posting is provided "as is;" no 
representations are made that the content is error-free or up to date. Designers should test 
their design in XHTML often and keep back up files at all times.

Please check you have the latest Widget. Go to Design Reporting Support Hub to download.
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Introduction
Welcome to Workiva! We are a cloud-based reporting compliance platform that 
enables the use of connected data. Workiva is also a great platform for design. 
Follow these guidelines for the best experience for you and your client. 

The Widget is your design reference and accompanies many online video 
workshops to help get you started.

Workiva is flexible regarding design. Design can be achieved within the Workiva 
platform, exporting content to Adobe InDesign or a mixture of both.

The Widget Platform guidelines gives 
you all the guidance about achieving 
design within Workiva.

The Widget InDesign guidelines 
contains information about using 
content from Workiva and using 
InDesign to create the design.

More details can be found on here so make sure you have the right Widget as your 
resource. You might need to download both! The Widget Export for web is also 
available.
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Designed Reporting 
Support Hub
[Bookmark this] so you can find it 
again easily! The hub contains a 
wealth of resources which will make 
your journey to structured data with 
design worthwhile.

Watch a webinar!
[Quick look to how design works with 
Workiva]

[See how a client and agency works 
together]

Watch a workshop!
These workshops take you on a 
journey from an ‘Introduction 
to structured content’ to ‘Building 
digital value’ - for designers and 
clients.

Are you stuck?
We have many short videos addressing 
individual topics. Don’t struggle or get 
frustrated - check out this section on 
the designed reporting support hub.

Why not get certified?
On the Workiva Learning Hub,
there are three modules for designers 
to receive a certification award.

[Design Reporting: Starting off the 
right way]
This module is for designers new to 
Workiva. We introduce the power of 
structured content and ways 
designers can use Workiva. Join us on 
a tour of the platform as we show you 
the best way to start your project for 
best results further down the line.

[Using Workiva and InDesign]
Module two looks at on-platform 
communications for designers, flowing 
content to Adobe InDesign while 
maintaining 100% data assurance, and 
managing exports and RGB and CMYK 
workflows in a way that meets your 
online and print quality requirements.

[Workiva, a design platform]
Here we explore using Workiva for all 
your design needs. Find out about 
design tools for creating charts, using 
presentations, and pushing content 
online via the Workiva web API.
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Getting started guides
If you are new to Workiva and are looking for a quick 
guide as you get more familiar with Workiva and 
Design Reporting, start here with our Quick Start 
Guides! Available in German, Italian, Swedish, French, 
Spanish and English. Find them on the Design 
Reporting Support Hub.

The Widgets
The Widgets - Platform and InDesign Integration are 
your guide on how to use Workiva and best practices 
for the whole design process. Download the latest 
edition on the Design Reporting Support Hub.

Help guides
Short, visual instructional guides to aid in quick 
understanding of the processes. Available for 
download on the Design Reporting Support Hub.

General platform support
If you need support about the Workiva platform, there 
are many resources at Workiva Support. Here there 
is information on XBRL, Wdata, documents and 
spreadsheets all the way to filing.

If you are new to Workiva, there are loads of basic 
guides to the Workiva platform here.

Need to contact a human?
So what do you do after you have checked all the help 
material? The best way to find further help is to 
contact the Customer Success Manager. This CSM is 
the person dedicated to your client’s account. They 
can help you straight away or direct your question, if 
design related, to Workiva’s Design Support team.

Out of hours
If you are logged into a Workiva account, you can 
submit a ticket at Workiva Support. A member of 
the Support staff will respond quickly. This support 
is 24/7.
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Have a smooth journey with InDesign Integration
You are reading this because you need or want to integrate InDesign within 
the Workiva platform.

InDesign is the worlds leading DTP (Desktop Publishing) software and as 
such is a mature tool used in many industries by different types of people. 
Our challenge here is to identify the tool subset needed by annual and ESG 
reporting and the skillset needed to integrate Workiva content successfully 
with 100% data assurance.

Workiva is totally flexible
Workiva isn’t just about the numbers. The platform offers a high level of design 
capability for your reports that reflect your brand and tell your story. For higher 
fidelity of design or if you are printing your report, you may still wish to use 
InDesign, the professional print publishing software.

You can use the platform in many ways for your report, so check that your design 
workflow is correct for your situation:

Options to discuss with your client
1. Here everyone works together in the same workspace from authors and audit, 

narrative and numbers and yes, designers. Your PDF, XHTML and iXBRL file if 
required are all generated straight from the platform looking exactly how it looks 
in Workiva. Please read The Widget - Platform for this option.

2. If the whole report is to be designed completely out of the platform, you can 
do this too, still with all the data assurance that Workiva brings. 

3. For some reports, higher fidelity of design may be required only on some pages. 
As with option one, all content is authored, tagged and audited in Workiva. 
Content in Workiva that requires more design work can be sent to InDesign but 
still linked to the platform. For PDF output, content can be exported from 
Workiva and InDesign and stitched together. If XHTML is required, the InDesign 
pages are imported back to Workiva for conversion. Please note that InDesign 

content is not used to update content in the Workiva platform. That content is 
only converted into XHTML. Please also read The Widget - Platform.

4. Some clients choose to file straight out of Workiva but produce the PDF from 
InDesign. All the content is authored in Workiva so that the content of both 
versions remains identical. Discuss with your client about the design 
requirements of the filing version.

5. Some clients use Workiva only for the financial section. The rest of the report is 
created elsewhere.

1 Everything done in Workiva 

2 Full InDesign integration

3 Mixing the solutions

4 Splitting the solution

5 Workiva only for financials
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Why use InDesign and Workiva?
Your decision to use InDesign might be one of the following:

• The design requirements are beyond the capability of the Workiva platform.

• The report is going to be professionally printed - this can be done using the 
Workiva platform for design but post-production software would be required.

• You want to stay designing in InDesign - this is understandable but check out all 
our training material on the Design Reporting Support Hub!

When does InDesign integration with Workiva 
work best? 
Case 1
Design quality with lots of last minute amends: A recent client knew that they 
would get many amends two days before filing. By keeping the ICMLs linked until 
the very end of the project the designers were able to deliver 10,000+ amends in 
a matter of minutes just prior to filing.

Case 2
Design quality with data assurance: A recent client had a very creative story telling 
brief with their annual report and felt that InDesign was the best and easiest way to 
achieve that with ultimate “no compromise” design integrity. 

Jurisdiction consideration - For reports that need to adhere to the 
European Single Electronic Format (ESEF) - look out for this sign
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Quick guide to InDesign integration
Below are the simplified steps to InDesign integration with Workiva. Following 
these steps carefully will guarantee 100% data assurance.

Step 1 Setup style guides in Workiva platform.
Step 2 The report content is created in Workiva and sent to the designer via 

ICMLs.

Step 3 Place ICMLs in InDesign. This can be done multiple times after edits.
Step 4 Create extra styles for non-Workiva content, edit style attributes 

and design!

Step 5 Content remains linked so no need to check amends.
Step 6 Audit and tagging all goes on in the Workiva platform.
Step 7 Export your IDML and convert to XHTML at Workiva, if required. 
Step 8 iXBRL file from Workiva and PDF from InDesign.

Benefits to you, the designer
Workiva is the single source of truth where the client creates and edits the content 
for the report. You receive this content via linked ICML files which you place in 
InDesign, just like an image. You can still design but without the fear of accidentally 
changing the content or forgetting to do a correction, so the data assurance still 
remains 100%. 

Jurisdiction consideration - Ultimately these steps will result in an 
iXBRL file that will look exactly like the PDF. We recommend that 
designers test early and get confident with this process.
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Workiva can import content from Microsoft 
Word (.docx). Even if you are designing in 
InDesign, your content authors are working 
in Workiva. They can start with a blank 
report or you can, for example, import a 
previous year’s report. 

Don’t rush this part. Take your time. 
Ask where did this Word file come from? 
Originally created in Word (great!) or a 
converted document from PDF (not great)? 
Follow these guidelines for a successful 
outcome when exporting out of Workiva 
at the finish of the project. 

Importing into Workiva
Starting with InDesign
In InDesign
A Check the styles are not in folders

B Make sure that all the styles have CSS compliant 
names - no spaces, do not start with a number 
and contain no special characters. Tip: Stick with 
Alphanumeric names, Camel-case or hyphened.

C Make sure all colors are RGB not CMYK

D Copy Content in sequential order from InDesign 
to MSWord

In MS Word
A Check styles are applied properly in the Word 

file

In Workiva
B Import the Word file into Workiva - File>Import

C Make sure styles are applied properly In Wdesk

D Perform any reformatting as needed

Starting with Word

In MS Word
A Check if this is an original Word document - see 

Old document concerns below

B Check all the styles are applied properly 
throughout the document

C Import into Workiva as above

Old document concerns
Workiva can import a .docx file but designers need to 
be careful about where this Word file originated from. 
This is because it could contain:

• Hidden characters
• White space
• Tabular matter (tabs)

You might not see it in the Workiva platform, but it 
could create issues with exporting to ICML and 
XHTML later on. 

If all you have is a PDF?
If all you have is a PDF document or Word document 
converted from a PDF, then we advise pasting the 
content into an ASCii text editor (Notepad++ on PC) 
first and highlight tabs or other whitespace 
characters and then open this text file in Word before 
importing into Workiva. You can use a search and 
replace to remove such items. This will take out all 
styling which you would then have to create and 
apply in Workiva. It will however remove all the 
potentially risky hidden code.

Importing content into Workiva

Document setup starting with 
InDesign

Document setup datasheet 
available on design reporting 
support hub
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Roles and responsibilities
We really recommend that designers are allowed into a client’s workspace.

Sharing of typesetting responsibilities
Workiva is collaborative platform environment where content creators, auditors, 
taggers and designers can all work together. This is great but could possibly 
become crowded unless managed properly. 

Projects go more smoothly if: 
• Everyone on the teams understands the basic structure of the report, applies 

the styles correctly and consistently
• Designers create enough styles for the whole report. This will help stop authors 

either creating unnecessary new ones or applying an override to existing styles
• Designers educate the team on when to use certain styles
• Designers check typesetting throughout the reporting cycle

Use of permissions
Permissions can control access to all or part of a document. Designers can use this 
when actively designing a section. Use the Advanced Permissions for this. You can 
easily revert to the previous permissions when you have finished.

Project calendar
Workiva can present a slightly different timeline to what you may be used to. There 
is a time element to importing content correctly on to the platform and to creating 
and applying styles. The design tools might behave slightly differently to what you 
are used to, which may impact your timeline and project calendar.

Use of blacklining
Blacklining is a great way to find where amends have been made on the Workiva 
platform. See the section on Blacklining ICML milestones and blacklines.

Remember, designers do not have to worry about amends or last minute changes! 

We do encourage some upfront training. Our three design modules are less than an 
hour each and will really help you with your design implementation. Find out more 
on the Design Reporting Learning Hub.

Allow a bit more time up front but less time should be necessary further on up to 
filing day.

Introduction to structured 
content

An introduction to the Workiva 
platform for designers

Helping workflow
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For the Workiva platform to interact well with the InDesign software, 
you need to set up your report correctly. Taking the time now will reap 
benefits later on in the project. 

Setting the document outline
The document outline represents the structure of the ICMLs. There is one ICML for 
each section or child of section. For example, if there are 100 outline (Index) items, 
there would be 100 ICMLs.

Top tip: Be aware that your exported folder structure may not appear in the 
exact same order. We cannot control how folders are ordered locally.

Create your style palette
All content in the Workiva platform should have a style attached to it. Styles can be 
amended on the platform to more closely align with your Design styles, if required.

For ICML export, the ‘Normal’ default style will be converted to the Bodytext style. 
See the section on Style Guides.

Headers and footers
Headers and footers can be generated in the Workiva platform however they 
do not export via ICML to the InDesign software. The export can only send content 
in between the grey dashed lines at the top and bottom of each page of the 
document.
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Typesetting considerations
Typesetting takes place in the Workiva platform not in the InDesign software. In 
multi-channel publishing, best practice is to not use a soft return (Shift Enter). This 
creates a line break rather than a paragraph break. Click the Show/hide non 
printing characters on your Edit ribbon to see all soft and hard returns.

See Typographic layout for more considerations.

Page formats 
It is important, in a multi-channel 
publishing scenario, to match the 
page format, margins and gutter 
measurements between Workiva 
and InDesign right from the 
beginning. A prominent reason for 
doing this, is the limitation in ICML 
of adjusting table and column 
widths. Therefore, these need to 
be the same in the Workiva platform 
as it is in the InDesign software. 

Caution: If you do not match page formats between Workiva and InDesign, 
every table width will need to be adjusted. Your report may contain 300+ tables. 
This is to be taken very seriously!

For details on how to edit the Document properties of a platform document please 
see The Widget-Platform.

Landscape v portrait
Traditionally most annual reports use a portrait presentation but increasingly 
landscape is being used for better onscreen consumption. Landscape formats 
can be used.

The double page spread
The concept of spreads is limited within the current iXBRL inline reader. Designers 
need to be careful when relying on a spread to convey information as this will be 
broken into two separate consecutive pages. It is possible with the help of web 
development to present spreads within the inline viewer so please talk to your web 
team if spreads are required as part of the inline viewer experience.

Mirrored margins
Often, in the case of a document going to print, the inner margin will be wider than 
the outer margin because of the act of stitching. This can present a problem of 
readability when presented digitally in both PDF and XHTML. Consider adjusting 
margins for digital presentation. 

Jurisdiction consideration -for XHTML think about the use of double 
page spreads and mirrored margins in the design

Justified verses range left video available on Design Reporting Support 
Hub

Margins and gutters
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Cell styles
The Workiva platform does not use cell 
styles. The ICML and XHTML exports 
contain an algorithm that summarises 
design parameters into cell styles for 
InDesign and CSS respectively. 

Top tip: The automatically 
generated cell styles within the 
exported ICML are built around 
the following parameters: 

• Cell vertical alignment 
(Top Middle or Bottom)

• Cell edge weight and color 
(all 4 edges are unique)

• Cell fill
Every unique variation will create 
a separate style.

So consistent styling and alignment 
is key to limiting the generated cell 
styles to as few as possible. 

Inheritance
The ICML export now uses the 
concept of inheritance or ‘Based on’ 
in both character, paragraph and cell 
styles. This is extremely useful for 
designers to be able to control large 
amounts of styles efficiently. 
Particularly the auto-generated styles. 

Top tip: All cell styles in 
the InDesign software are auto-
generated. They are based on a 
style called NoRule so CellHeight 
can be controlled using PaddingTop 
and PaddingBottom from here in 
the InDesign software. 

Cell types in Workiva
Designers new to the Workiva platform 
need to be aware that the cells are 
active in terms of content formatting. 
For instance, cells can be nominated 
as accountancy, text or number with 
decimal places automatically 
attributed. 

Table and column widths
Designers need to be aware that table 
and column widths cannot be altered 
in linked ICMLs. These need to be 
correct in the Workiva platform. 

Top tip: For a more information on 
how to style and work with tables 
on the platform, please see 
The Widget-platform.

Colored brackets
You may see Colored brackets around 
financial figures when you place your 
ICML files. These are placeholders for 
the XBRL tagging and do not hinder 
your design capabilities at all. You can 
just ignore them. 

Top tip: Tables in the Workiva 
platform must be set to the correct 
width. This cannot be changed in 
the InDesign software.

Table or galley?

Successful Workiva table 
formatting and InDesign
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Workiva is a multi-channel publishing environment. Content created within 
documents can export to a variety of outputs - PDF, HTML, DOCX, ICML and 
XHTML.

Because of this reusability of data, designers need to work with structured content 
and Workiva structures that content by using styles.

Style guides
A style guide is a set of standards for the design of a document that ensures 
formatting consistency throughout and/or across multiple documents.

Set up the styles
There are two ways a designer can do this
1. Set up the styles in the Workiva platform
2. Create the styles in the InDesign software and import back to the Workiva 

platform via Microsoft Word document/software

What to call each style
You need to consider styles for all your content. When choosing a style name, it is a 
good idea to choose a name that reflects the use of the style, for example: 

CaptionSmallBlue or TableTextBold

This will help everyone on the team understand the structure and apply the correct 
style to the content. We call this semantic styling.

Styles always start with a letter No spaces or special characters

Style names can contain letters and numbers but should always start with a letter. 
For example:

Heading1 is good ☑. 1Heading will not work ☒
Characters such as - !@#$%^&*()_+-={}:”<>?[];’,./`~ etc and spaces must be avoided. 

Lock the styles
Once created, designers can lock the styles and their attributes. This stops authors 
changing an aspect of that style. You can lock:

• The font family, size, color and emphasis
• Alignment, spacing and indentation

Top tip: Designers can also add a note to the style. This might help your user 
when choosing the style. When they hover over the style in the style palette, the 
note appears alongside the style attributes.

Benefits of using a well constructed stylesheet
• Efficient authoring for clients - you want everyone to be a good typesetter!
• Document health and consistency
• Easier evolution/rollover of styles in subsequent years
• Value creation - enables your report to be used by Workiva’s WebAPI for example

Top tip: Don’t use the ‘Normal’ style in the Workiva platform. The InDesign 
software can have issues with this default style. Bodytext is a special style and 
should be the same in both the Workiva platform and InDesign software

Exports from Workiva

Importance of a style guide

Importing content into Workiva
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Top tip: Take time to set up styles 
properly at the start of your project 
- it really does save time later

Top tip: It is best practice not to 
use the ‘Normal’ style in the 
Workiva platform. Turn default 
‘Normal’ to pink to identify this un-
styled content.

Top tip: If the ribbon is clicked to 
amend the style of selected text in 
the Workiva platform then an 
override style will automatically be 
created. This is clearer to see when 
ICML is being exported as each 
overridden style will create 
a unique style in InDesign.

Top tip: Table styles do not import 
from Word, so any Table styles will 
also need to be applied to at least 
one line of copy (outside of a table) 
for that style to appear in the 
custom style palette. Those styles 
will then need to be applied to all 
the tables on the platform.

Quicker application 
of styles
Text can be selected in a whole 
section and a style applied but 
generally you wouldn’t want to style 
a whole section in one style (unless it’s 
a brand new copy and applying one 
style is the ideal starting point).

If however, you have a style you need 
to apply throughout a section or an 
entire report quickly and consistently 
then the best method may be to use 
the format painter.

The format painter is in the Edit menu 
and to use, you just need to do the 
following:

1. Select the style you wish to copy 
with your cursor.

2. Click once on the Painter icon and 
a border will appear around it 
showing the style is loaded.

3. Click the copy you wish to apply 
that style to.

If you want to apply that style to 
multiple lines of copy, in more than 
one location, then at step 2, double- 
click on the Painter icon (which will 
give you a thicker border around the 
icon) and apply. The style will remain 
loaded and be applied until you click 
on the icon again to switch it off.

Top tip: Be aware that if used in a 
table, cell styles and rules will also 
copy (top, left, right and bottom 
rules), so it may be simpler to apply 
styles in tables manually.

Top tip: Don’t use tabs! Create an 
indented style

Why have I got so many 
styles?

Rogue styles

Format painter icon

Format painter icon 
after 1 click

Format painter icon 
after 2 clicks
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For XHTML, only RGB colors 
must be used as RGB is the only 
color format supported on the 
web. The InDesign software 
uses CMYK and Pantone spot 
colors for the printing of ink 
on paper. 

The web cannot use these color 
formats as RGB is the default color 
space of the web. If the InDesign 
software is being used to author and 
this content is to be converted to 
XHTML then RGB (Red, Blue, Green) 
colors must be used.

Converting CMYK to RGB is not 
straightforward. So it is best that 
designers specify RGB in their 
InDesign documents so accuracy is 
maintained and there are no surprises 
when converting.

Jurisdiction 
consideration - RGB 
colors must be used for 
ESEF filings

Hex is another way of describing RGB 
color in base 8 (hexadecimal). Pantone 
colors (spot) are used in printing. The 
ink used is the actual color specified 
instead of being made up of CMYK 
colors. They are often specified in 
branding guidelines for a corporate 
color because of their accuracy. It is 
advisable to always check branding 
guidelines for specific colors rather 
than relying on conversion.

Top tip: All colors need to be in 
RGB for web use

Top tip: Remember screen 
limitations when choosing colors 
for the web. 

Top tip: Make sure you have 
enough color contrast for good 
readability for all users. This can 
also be an audit issue.
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Using the color palette
The platform color palette has 64 
standard colors but beneath that is 
a custom color area which allows for 
up to 16 custom colors to be stored 
and displayed at any one time. 

The custom color area would be where 
you would add document specific 
colors.

A color palette is only linked to a users 
own account and therefore to give 
additional users the same custom 
colors, it is necessary to input them 
into each users’ own custom palette 
separately.

The same color palette will be 
displayed for any platform function 
that requires a color choice.

Adding custom colors 
To add a custom color to your palette 
you only need to open any color 
palette from the main menu (i.e. Text 
Color, Highlight, Background Color, 
etc) and in the Custom Colors box add 
your Hex reference for your desired 
color and then click add.

This will add the color to the top left 
custom color box and move all the 
existing colors along one. If there are 
already 16 colors then the last color 
will drop off the end of the list.

Managing RGB and CMYK 
workflows

More information about the use of 
custom colors at Workiva Support
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Licensing
For publishing in XHTML, companies need to own the web usage rights of any font 
weight being used in their iXBRL/XHTML file.

At the moment an iXBRL filing constitutes web usage. It is recommended that 
companies check the licensing status of all fonts they are using. Also, issuers 
cannot rely on suppliers to do this for them or indeed hold such a licence on behalf 
of the issuer. In addition, licensing is based on a per font ‘weight’ basis so if you are 
only using two weights of a font family you only need to comply for those weights. 

If the font is available in the Workiva platform, then the font is open source or has 
the appropriate license in place. We advise designers to check with their client 
regarding font usage if they are not in the Workiva platform.

Open source fonts
Google fonts and other ‘free to use’ fonts may be worth considering not only for 
cost reasons but because they are especially tailored for the web.

Web fonts (woff and woff2)
Web Open Font Format is now the standard for font usage in browsers and OTF and 
TTF fonts will be converted to these formats at upload time. Supported browsers 
and versions are below. Discussion is taking place re TTF support for older versions 
of these browsers.

Testing font rendering in browsers
It is important that designers test font rendering in browsers to avoid unexpected 
effects. It is critical that font choices are made with such knowledge. Also, some 
italic font weights and some older sans serif fonts are prone to not looking very 
good when rendered in browsers. We recommend testing fonts early.

Fonts not in the Workiva platform
Please ensure that fonts used in the InDesign software are uploaded with your 
IDML at conversion time. You will need to zip the IDML and font folder for the 
import. If the fonts are available in the Workiva platform, this step is not necessary.

Jurisdiction consideration - For ESEF, fonts used in iXBRL format 
must converted to base64 format and embedded in the CSS

Custom fonts
These include fonts constructed for licensing reasons or decorative usage 
within text. Please test thoroughly with the IDML>XHTML process so that you 
are confident that the font construction is suitable for the Workiva platform 
conversion process.

Renaming of fonts
Please be aware that renaming fonts can render them inoperable or cause them not 
to appear. The Workiva Integration Tool (plugin) log file specifies both familiar and 
postscript names of fonts being used in a document. 

Link to list of fonts on platform
[Click here] for an up to date list of supported fonts.
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Widow management
One definition of widow management 
is making sure that the last line of 
a paragraph isn’t a single letter, word 
or number. This can look ugly and add 
unnecessary whitespace into a design 
and make the content longer than it 
needs to be. Designers have deployed 
a number of methods over the years 
with InDesign to remove widows.

The soft return method
This method is now widely depreciated 
in multi-channel publishing because 
text frame widths can vary in 
responsive layouts. Soft returns can 
have unfortunate consequences in 
such layouts. Browser rendering 
differences can also have the same 
effect.

The kerning method
The previous line(s) to the widow are 
highlighted and the inter-character 
spacing (kerning) is reduced allowing 
the widow to move up onto the 
previous line. This can be replicated in 
XHTML but can have unforeseen 
issues in the rendering of that content.

The condensing method
As above but instead of kerning the 
characters are condensed in width (eg: 
95%). This can be replicated in XHTML 
but can have unforeseen issues in the 
rendering of that content.

InDesign compositor 
method
The InDesign software has an 
algorithm that can avoid widows. It is 
not recommended for multi-channel 
use and is not deployed by designers 
for responsive design.

Recommended method
Our recommended method of widow 
management is the use of nbsp. This 
can be done in the platform easily and 
is exported via ICML and converted via 
IDML into XHTML.

The non-breaking space 
(nbsp) method
Widely regarded as the best way of 
controlling widows in multi-channel 
publishing. The break between 
words is filled with &nbsp; or &#160; 
effectively making two words one 
word. This is ignored by search 
engines and can’t be seen by 
human readers. This also works in 
responsive layouts as it only comes 
into force when a text frame width 
conflicts with that set of words 
forcing all of it onto the next line 
therefore preventing a widow. They 
are also used to keep names, place 
names, company names and sets of 
figures together.

A note on design
As we move into a multi-channel 
environment and the use of nbsp is 
accepted as the only way of managing 
widows, designers need to think of 
their designs and allow a little more 
whitespace in their layouts. To get the 
best from multi-channel publishing, 
think XHTML first.

Hanging indents
Designers may need to experiment 
with the kind of bullets they wish to 
use for bulleted lists. Wingdings, Zapf 
Dingbats or other kinds of font 
libraries can be used if there is a 
Unicode equivalent. These need to be 
tested early to make sure that they 
translate as expected.

If designers wish to use icons or 
images as bullets then they will need 
to edit the CSS in post-production. 
Expertise will be required for this as it 
is not something Workiva can support.

20

Typographic layout



Hyperlinks
External hyperlinks are supported.

Jurisdiction 
consideration - external 
hyperlinks are not 
allowed under the ESEF 
mandate

Justified text
Whilst not strictly a font issue, it is very 
important to note that XHTML is poor 
at rendering justified text in multi-
column format. The InDesign software 
has very sophisticated tools for 
justification that cannot be replicated 
in XHTML. Please avoid if you can and 
use range left (called ragged right in 
some jurisdictions).

Justified verses range left 
video available on Design 
Reporting Support Hub

Grep
Grep (global regular expression print) 
is used a great deal by designers to 
control many aspects of typographic 
layout. There are two types of Grep 
within the InDesign software. 

Grep within styles
This is sometimes called nested 
styles. These are regular 
expressions that match certain 
patterns based within content 
that is styled with a particular 
style. The Workiva platform does 
not support Grep within styles. 

Grep within Find 
and Replace
These are regular expressions 
used within the ‘Find and Replace’ 
function of the InDesign software 
and can only be used on unlinked 
content. These are permanent 
alterations to the content. This 
can be done after the ICMLs are 
unlinked in preparation for the 
conversion process of 
IDML>XHTML.

A good example of the use of Grep in 
the InDesign software with Workiva 
content is changing em dashes (U.S.) 
to en dashes (EU). A nested style can 
be applied to table figure styles to 
make that change on ICML content. 
That Grep will need to be applied with 
Find and Replace when the ICMLs are 
unlinked to make that change 
permanent. 

Lists
Custom styles for lists can now be 
created in the Workiva platform. These 
are still treated as an override but can 
now be identified within the InDesign 
software as that custom list style. 

For IDML export, do not split a bulleted 
item across text frames. The list can 
be in multiple frames but not an 
individual bullet.
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Many reports will also be printed in addition to any XHTML 
requirement. In this case designers will need to keep two sets of 
assets (images and charts) for different publishing channels.

Traditional print images
PSD and TIFF are common image formats for print often set at 300dpi (dots per 
square inch) and often CMYK. Resolution-less graphics such as graphs are used in 
Illustrator (AI) and EPS (Encapsulated Postscript) formats.

Web image formats
JPG, GIF, PNG (bitmaps) and SVG (resolution-less) are common web formats for 
images. Bitmap formats are often set at 72 or 96 dpi and are RGB.

Print Web (XHTML)

.psd (cmyk, 300dpi) .png (rgb, 72dpi)

.tiff (cmyk, 300dpi) .jpg (rgb, 72dpi)

.jpg (cmyk, 300dpi) .jpg (rgb, 72dpi)

.ai .svg

.eps .svg

Adobe Illustrator software is capable of producing both AI, EPS and SVG formats. 
Most image editors like Photoshop and GIMP can produce all bitmap formats.

The major difference in using images between print and web is that web images are 
cropped to the borders of the frame whilst images placed in InDesign are often not. 
For a traditional DTP designer this presents an extra process whilst for web 
designers, this is common practice. Designers need to find a dual solution that suits 
them and preserve appropriate quality for all channels.

Top tip: A quick way of cropping a large amount of images placed in InDesign is 
to export the document as a JPG at 96dpi. You can then open the pages in 
Photoshop or Gimp and crop easily there. You can then replace those images in 
InDesign with your newly cropped images.

Embedding images in InDesign
All images being exported in IDML must be embedded in the InDesign software. 
This converts the image to based64 code. It is this code that is copied into the 
XHTML. There is no manipulation of images. 

Print and web images
For designers setting up a document for both the iXBRL and PDF formats, there are 
two solutions to address the management of differing image assets. 

1. Use two layers - one for web and one for print
2. Use two folders and when it is time to change from one to the other, you can use the 

built-in swapping tool in the InDesign software.

RGB or CMYK first?
It is advised that designers work in RGB first and convert to CMYK at an appropriate 
time when printable artwork is needed.

Older JPG issues
JPGs (JPEG) can present certain issues as they can be saved/used in CMYK and 
RGB. Also, older versions of Adobe Photoshop software and other image editing 
programs present differences in ‘saving’ and ‘exporting’ to the jpg format.

Images over a double page spread
Large images used across a spread (two pages) need to be separated/split into 
single page usage.
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Images and file size
Images should be cropped to the containing frame size, reduced to 72dpi or 96dpi 
and be RGB. They should be of file type - png, jpg or gif. 

Infographics
The recent history of the InDesign software has seen it increase its ability to create 
more complex infographics. We encourage designers to test such pages in their 
reports with our IDML>XHTML converter. If the results are not satisfactory, 
because there are certain aspects we do not support, then it is very easy to convert 
such graphics to SVG. The steps to take are;

1. Copy infographic to Adobe Illustrator software
2. Save Illustrator file to SVG
3. Place SVG in the InDesign software to replace infographic

You will need to make considerations on embedding the glyphs of any fonts used or 
convert text to outlines.

Multiple effects and images combined as a single image 
It is possible, in the InDesign software, to create very complex, composite images 
using a combination of bit maps, gradients and other effects. These are not easily 
converted. It is better to take composite images and export them from the InDesign 
software to create a single image such as JPG, PNG and replace the composite 
image in the InDesign software with that image.

The infographic above was copied from InDesign to Illustrator and exported as SVG 
and placed in InDesign.

Easy image optimisation

Managing RGB and CMYK workflows
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ICML (InCopy Markup 
Language) is an official format 
of InDesign software and is used 
for importing and exporting 
structured content. It is a linked 
file meaning the content of an 
ICML file cannot be edited, 
within InDesign, unless the user 
breaks the link. This is the 
foundation of data assurance 
that Workiva offers when 
integrating with InDesign.

ICML - InDesign 
integration

ICML import best practice
Check all content is styled
Before you pull your ICML from the 
Workiva platform, make sure that all 
content has a custom style attributed 
to it. The default setting in the Workiva 
platform is ‘Normal’ and this style is 
converted to Bodytext on export via 
ICML. An easy way to identify ‘Normal’ 
is to change its color to a contrasting 
color for easy spotting eg bright pink. 

Top tip: The “Normal” style will 
always be changed to “Bodytext” 
in ICML export. So it’s a very good 
idea to always create the 
“Bodytext” style (the exact spelling) 
in you custom styles so that you 
can control the look and feel of 
the style as exported in ICML.

Import early
We recommend importing fairly early 
in the reporting process. Subsequent 
timings of ICML pulls should be 
discussed between designer 
and client.

Import a quantity of ICMLs 
before changing attributes
One ICML represents one outline item 
in the Workiva platform and this ICML 
only imports the styles associated with 
that outline (section). 

It is recommended that designers 
import enough ICMLs into InDesign to 
capture all the custom styles being 
used before making any changes to 
those styles.

Using the ICML to spot and 
correct style irregularities
All content will come through with 
a style in ICML. So any overrides 
applied to text will be picked up 
and cause an additional style to be 
created. Some of these differences 
may be wanted and some may not.

These override styles will normally 
contain the base styles name, followed 
by a string of numbers.

Once all the ICML has been imported 
the designer can look through their 
InDesign file and review these styles. 

Using the Find/Replace in InDesign, 
you can search for where a style is 
used. You will need to include locked 
stories and maybe locked layers, for 

the search to identify styles used in 
the ICML.

You can also check the General tab in 
a styles options in InDesign, as it may 
tell you straight away what the 
override is. i.e. a right indent would be 
visible as extra info in the general tab. 

Once the override is identified, correct 
it in the source document, re-export an 
ICML and if all instances of the 
override are removed then the style 
can be removed from InDesign using 
‘Select all unused’ in the style list and 
then deleting the unused styles. 
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ICML export
Exporting ICML is done by choosing Save As > 
InDesign (.icml) from the file menu but here 
we will walk through the process with an 
example section.

Here is a section called ‘Company information’ 
which has content over 3 pages and a couple 
of pictures uploaded onto it.

To export this as ICML, do the following:
From the File menu, choose Save As / InDesign (.icml). 

This opens up the ICML Export Options window. 

Here you have the option to export in the following ways:

Entire Document
As the name suggests, this will export the 
whole Project to ICML.

ICMLs are exported within a folder structure 
that represents the Workiva platform outline 
for easy identification. 

When initially linking a project’s ICML to your 
InDesign file, it is a good idea to export the 
Entire document, as this will be your folder 
structure  going forward. 

 

Top tip: If a section moves or is renamed 
then it will change in this folder structure 
as well.
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Current Section
This will be the section you currently have selected in the Index, in our example we 
have ‘Company Information’ selected in the Index.

Select Sections...
Select Sections allows specific sections to be selected. Clicking on Select Sections 
will open up a menu where all the sections are listed and you can select whichever 
sections you wish to export.

Advanced
The Advanced menu sits under the export options and allows for some further 
tweaks to your export.

These are:

Combine Subsections into Parent Section - This will combine child sections with 
a parent section. Consider carefully the pros and cons of combining sections.

Top tip: If sections are combined, you would need to do this every time you 
export those section to get the same ICML content.

Use Fixed Row Heights - This will export table rows with a fixed height, based upon 
the height set on the platform for each row, as opposed to row heights being 
changeable through the cell styles in InDesign. 

Top tip: If row heights are fixed in the ICML export then if there is overmatter in 
a table, it will also be obscured in InDesign. Always preflight your InDesign file to 
spot this.

Use CMYK Colorspace -This will convert all text and tint colors from RGB to CMYK 
in the ICML. There is no control over the conversion, so if you plan to color correct 
your ICML in the future then you are probably best off sticking to an RGB workflow.

Export gutters - This positions currency symbols in nested tables into a separate 
cell for alignment. This is generally only used for US customers.
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Once you have selected your options you, click Export and your chosen ICML will be 
downloaded to your Downloads folder.

Whilst downloading 
a small popup will 
appear on screen.

The zip filename will always be the same as the document it was exported from.

The zip file will contain folders named, as per the sections your chosen ICML were 
contained in. The zip will also contain the ICML files and any images contained 
within the sections.

In our example section we had 2 images. In an InDesign/ICML workflow, you would 
normally use the images contained within your artwork file as opposed to the 
versions exported with any ICML.

The downloaded ICML and/or folders can now be moved to where your ICML are to 
be stored for the remainder of the project.

Top tip: Never link to ICML directly from a downloads folder. You should always 
have your master ICML files located in one location and override them as 
required after a new extraction.

Place ICMLs
To place an ICML file you can either, in your InDesign document, go to File>Place 
and navigate to your ICML file or simply drag and drop the ICML file straight 
into InDesign. You can also place ICML straight into pre-created text boxes (as long 
as no other content already resides in them).

Once placed, the ICML can fill one or multiple linked text frames and a link to the 
ICML will be created in InDesign. It works similar to how a picture would link.
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Below we have a sample ICML, laid our in our InDesign file. Some text styles have 
been modified and imagery added. 

The lines that can be seen running from the selected text frame to the others on the 
page are called Threads and these show the flow of the content between linked text 
frames. These can be switched on and off though the main menu View>Extras> 
Show text threads. 

The text frames holding the ICML content can be placed at whatever size and 
position the designer requires but the ICML content will always flow in the 
same order.

Maintain the links
Once the InDesign document is built and the ICML are linked, your Links panel is 
the easiest place to see which ICML is which. If you right-click on a link in this panel 
and select Go to link then InDesign will jump to the link’s location.

For data assurance and so that you don’t need to worry about versions or checking 
of content, make sure you don’t break the links of your ICMLs. 
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Update the links
When new ICMLs are exported from the platform, it is best practice to overwrite the 
previous linked ICML. This is because you don’t then need to relink the ICML in 
InDesign but instead can just update the link.

To do this you need to:

1. Export your new ICMLs
2. Unzip the new ICML zip file in your downloads folder
3. Locate the ICML folder that InDesign is linking to
4. Either replace folders with folders or individual ICML with individual ICML. 

The main thing here is not to break the structure as each ICML linked. InDesign 
will retain the network path and that is what you don’t want to break.

5. An updated ICML will appear in your InDesign file with a small Triangle next to 
its name.

6. Right-clicking on an updated ICML or group of ICMLs in the Links panel will bring 
up a window where you can choose to ‘Update Link’. Clicking this will update the 
ICML in InDesign.

Top tip: If there are many ICMLs to update then it can be quicker to have your 
InDesign file closed whilst you replace the ICML files and then upon opening 
InDesign you will get a prompt to update all the links. This will speedily update 
the ICML as opposed to update them in groups or individually.

It is up to the designer whether you wish to keep all previous ICML exports but the 
history of changes is also stored on the platform with the source content.

Updating the ICML will only bring through the fresh content for that section. All 
your design values will remain in place.

Style changes
Each ICML will bring with it the styles used on the platform for that section. 
They will only come in with the first ICML import and will not be overwritten by 
subsequent imports. 

This allows the designer the freedom to modify the styles parameters in InDesign 
(but not the name, as that is required to perform the handshake with the ICML on 
where the styles are applied). So, for example Heading1 can be changed in InDesign 
to a different color and all Heading1s in InDesign will appear that color and any new 
ICML pulls will still appear with that color. 

This does not change the color settings on the platform file however and if styles 
are to match then the same change would need to be made there. Also, as ICML 
styles do not overwrite in InDesign then changing the color of Heading1 on the 
platform first will not overwrite the style settings in InDesign.

Apart from with the first ICML import, the only other time a style will come in new, 
is if it was renamed on the platform or a newly named style is added (you can see 
the importance of names). So changing a style attribute in the Workiva platform will 
not update the corresponding style in the InDesign software.
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ICML milestones and blacklines
When you have decided, with your client, dates for ICML imports to the InDesign 
software, it is a good idea to create a milestone in the Workiva platform. This means 
you can track content changes between the subsequent ICML pulls by creating 
a blackline.

This is also really useful for seeing what sections have changed, as you may only 
need to export a few sections as opposed to the whole document and it can also 
help to show where large content changes have been made, which can help you to 
potentially re-layout a section before a proofing date.

Towards the end of the project, we advise doing one whole ICML pull of the whole 
document to absolutely make sure every ICML is the current one.

Creating a milestone
To create a milestone in a Workiva document you need to access the document 
History panel. It will be one of the tabs to the right of your screen.

From here you can either create a brand-new Milestone by clicking ‘Create 
Milestone’ or you can select any existing date and time and create a milestone 
there. This is done from the dropdown alongside the date.

The milestone will ask you to give it a name (‘Proof’ has been used for this example) 
and add any remarks (optional). Then click Create and the milestone is created.

The milestones standout in the History list, as they have a small diamond next to 
them and the History list can also be filtered to only display milestones.
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Creating a blackline
To create a blackline on the platform, go to the History panel of your document (a 
tab on the right-hand side of the screen) and click the dropdown menu for either a 
date and time (revision) or a milestone and select Create Blackline.

This will open up a box at the top of the History panel with your selected revision/
milestone at the top and a space for the comparison revision/milestone. 

Any revision/milestone can be just dragged and dropped into the ‘Drop Milestones 
and Revisions Here’ box.

Also, if you only want to see what sections have been amended between the two 
points in time then you can tick ‘Only include sections with changes’.

When you have made your selection, click Create to generate the blackline.

Top tip: Using a blackline and selecting ‘Only include sections with changes’ is a 
great way to see what sections need to be exported as ICML, which can help 
speed up the process when pulling through new ICML.

The blackline will appear in the Blacklines menu. It should automatically jump 
to this menu but if not then it can be found in the tabs along the right-hand side 
of the screen. To open your Blackline, hover over it and use the dropdown to select 
Open.
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The Blackline will open in a new tab and you can 
scroll through the document to see all the changes.

To the left of the page view is a list of all the 
Sections that changes have been made in. If you are 
generating the blackline to identify what sections 
to download as ICML, then this list is where you get 
those names from.

You can also use this as a quick visual guide to how 
extensive the changes are and to make sure you 
have updated the ICML correctly.

Top tip: The Blackline opens in a new tab. 
To return to the main document just click the 
Main Documents tab or just close the new tab.
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Workiva Integration 
Plugin for InDesign 
Software
The purpose of this plugin is to 
support the conversion of InDesign 
to XHTML. Initial content should be 
created in the Workiva platform and 
exported as ICML, then imported to 
InDesign. The Workiva Integration 
Plugin for InDesign software should 
be used as designers are preparing the 
artwork, and before bringing the 
content back into the Workiva 
platform as an IDML file.

The plugin is provided so that 
designers have a validation tool that 
identifies issues within an InDesign 
document that would corrupt or are 
otherwise not appropriate for 
conversion into XHTML. This plugin is 
easy to import in both Mac and PC 
versions of InDesign and writes 
a report at the click of a button. In all 
cases the things we point-out are 
XHTML conditional and not a specific 
condition of the Workiva platform.

The Stop/Start button
If you want to monitor the ICML, 
use the Start and Stop buttons. 
You can press Start when the ICML is 

initially imported, or wait until later in 
the process. This is optional.

Import (ICML)
Locates the file exported from the 
Workiva platform.

Ungroup
All items should be ungrouped. 
This helps to ungroup all grouped 
items existing in the InDesign file 
in one click.

Validate
Pressing this button produces a log 
file (validation list) showing warnings 
based around converting this 
document from IDML to XHTML. 
This log file can be found in the same 
folder as the InDesign file (.indd). This 
should be reviewed before every 
import into the Workiva platform.

Validation list
Top tip: The validation list will let 
you know if something needs to 
be updated, or will include some 
best practice informational items. 

Split
Split will run through your file and 
break all threaded text frames into 
separate unthreaded text frames 
whilst retaining the content each 
frame held before splitting.

As of 2023 please review the “Block 
Tagging” section for more information 
in using split text frames.

Jurisdiction 
consideration - Due to 
the requirements of 
block tagging, ICMLs 
must not be split, except 
for testing or for the final 
submission version. 
The Split function in the 
Plugin must be used, as it 
sequences the frames, 
which is necessary.

Export (IDML)
Exports IDML from the InDesign file to 
your desktop.
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Year 2023 changes

Jurisdiction consideration - Please read this page if your report 
contains block tagging - for example filing under the ESEF 
mandate

Block tagging of the notes and eventually other areas has now been introduced in 
ESEF and such paradigms are likely to follow in global ESG taxonomies. So even if 
you are not involved in an ESEF project it may still be relevant to you if you are 
using InDesign.

So what is block tagging and why is it different from 
normal tagging?
A normal tag looks like the following;

<tag>item</tag> 

Whereas a block tag looks more like;

<blocktag>
    <tag>item</tag>
    <tag>item</tag>
    <tag>item</tag>
    Text can also be contained
    <img src=””/>
</blocktag>

In other words a block tag can contain other tags, multiple lines of text and even an 
image. Now let’s look at what the specific InDesign problem actually is.

Top tip: Block tagging needs the actual content in order in both human-readable 
form and the underlying XHTML code itself. So any processing of an InDesign 
IDML file will need to re-order that content if it is not in the correct order.

InDesign has no-sense of story order
When content from Workiva is placed into InDesign, the contents of a block tag can 
be split across multiple text frames and/or pages. That is what makes the non-
ordered InDesign stories a problem unless you give it something that any post 
processing can use to set that order. InDesign tends to work top-left to bottom 
right hence why skipping through a PDF from an InDesign file can, occasionally, be 
a problem. The code itself is laid down in the order that it is done, not the human-
readable order.

The solution
The Workiva Integration Plugin has a function/button to split text frames. You will 
now need to use this function instead of the InDesign built in script. 

This function adds a number in the script label that lets Workiva know the order of 
the text frames in a series of previously linked text frames. We can use this series of 
numbers to process the code in order. 
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Once the linked text frames are split via the Workiva Integration plugin, the 
following five text frames will have script labels as follows;

2466:1, 2466:2, 2466:3, 2466:4, 2466:5. The first part is a story identification 
number and the second part is the actual text frame number itself. So we now know 
the story order.

There are some edge cases to be aware of as well.

What happens if a block tag contains two sets of linked text frames or two 
separate text frames that have never been linked? 

Answer one: Start with the first text frame or text frame series and note the story 
number. In the following text frame(s) change the story number and the text frame 
number to follow on. So in the case below we have two sets of text frames after 
splitting that are nested in one block tag;

1066:1, 1066:2, 1066:3 - 948:1, 948:2, 948:3 

You will need to alter the second set manually to read;

1066:1, 1066:2, 1066:3, 1066:4, 1066:5, 1066:6

Answer two: You can alternatively join the two sets of text frames in InDesign before 
splitting and the above will happen automatically.

What happens if there is an image in the block tag?

Answer one: You need to add the numerical sequence in the images script label. 
The only exception is that the image cannot be the first or last in the sequence. 
Our processor will then know how to re-order the code in that sequence. So;

1066:1, + image + 1066:2, 1066:3 

Will become;

1066:1, 1066:2, 1066:3, 1066:4  ...where 1066:2 is the image script label and 2 
changes to 3 and 3 changes to 4.
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IDML export best practice
Export early and often
We recommend you export your IDML package early in your reporting process and 
do this often. We recommend this because:

• You become familiar with the process to save stress later on near filing
• You can check your design by opening it in the browser - does it look as you 

intended?
• You can check your design in the online viewer - how does it look?
• Check early so you have time to tweak your design if necessary.

The InDesign package
When first uploading IDML, it is always best to create a package that includes the 
fonts. It will also show over set text and other useful information about your file. 
Subsequent IDML can be exported with Apple or Ctrl e and the IDML file replaced in 
the original package. The Workiva platform only needs IDML and the fonts being 
uploaded to create XHTML.

The package panel from InDesign
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Converting your file
Once you have your zip or IDML file go to the Creation button in your Workiva 
workspace and click Import. You will then get an Upload panel where you can 
navigate to your zip or IDML file.

Where does my converted IDML file go?
It will sit on top of your files list along with the discrepancy report. The IDML file is 
not kept.

Discrepancy report
The discrepancy report will sit alongside your XHTML file with the appendage of 
‘Report’ in the name. This file gives you information about your conversion and will 
highlight issues, if they are present. Designers are encouraged to view this report 
after conversion.

Top tip: If you cannot see your discrepancy report then clicking twice on the 
‘Last modified’ filter, to the right of where the filenames are, will refresh the list.
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How to create an iXBRL file from my converted IDML
You will need to ensure you have access to the XBRL tab in your workspace.

Click on the XBRL profile and then the documents tab. It is here you “override” the 
default XHTML with your converted XHTML.

The left-hand side represents the documents on platform. The right-hand side the 
XHTML documents used to replace them. Clicking on the right-hand side will open 
a panel. Choose “Override XHTML” and your newly converted XHTML file will be on 
top (usually) of the file structure. Select that file. That’s it!

Multiple InDesign files
The override works as a 1 to 1 paradigm. If you have multiple InDesign files that are 
overriding a single Workiva document then you will need to create blank Workiva 
files as placeholders. You can add multiple documents on the left-hand side as well.

You can now create an iXBRL file by clicking ”Generate iXBRL” then “Full 
Generation” in the ribbon at the top of the Workspace.

A panel will appear on the right-hand 
side from which you can download you 
iXBRL package with the viewer for 
placement on corporate website or just 
the filing documents without the viewer 
for the regulator.
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IDML>iXBRL checklist
1. Save a copy of your master document first and use this copy to prepare for 

IDML export
2. Ungroup all InDesign grouped items via the Workiva Integration plugin.
3. Unlink all ICML files. This can be done in the links panel.
4. Split all connected text frames using the split story button within the Workiva 

Integration Plugin - as of 2023 do not use the split story script built into InDesign
5. Remove any hidden layers or layers used for admin purposes.
6. All images to be placed at 72, 96dpi (144dpi can be used in exceptional 

circumstances), RGB and cropped to the image frame. This will reduce the file size 
dramatically.

7. Use SVG only for resolution-less vector graphics, not .eps or .ai files.
8. Make sure there is no overmatter.
9. Make sure tabs have not been used. Please limit any overrides to a minimum.
10. When uploading IDML it is best to first create an InDesign package so you can 

upload any fonts not on the platform as well. You do not need to upload the .indd file. 
You only need the IDML file and the fonts as a single zip file.

11. Make sure you can access XBRL in your workspace
12. Liaise with your XBRL experts to ascertain the status of the tagging
13. Open your XBRL profile panel
14. Override the default Workiva XHTML with your converted XHTML
15. Create iXBRL
16. Download iXBRL package for viewing locally - with or without viewer

A page being viewed in an iXBRL viewer

How to build an iXBRL file in the 
XBRL profiler
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Many regulators are now stating a file size limit of 100 MB max. 

How do you stop a filing or download nightmare? How can you reduce the size of 
your report? Read on for tips for designers can use to optimise their file size.

For the designer in InDesign
Here are things the designer needs to do to reduce the final file size in Adobe 
InDesign software:

• Avoid empty paragraphs to achieve extra space in your document.
• Make sure all content has a style name attached.
• Make sure you crop all your images to the correct size, 100% and RGB
• Review your font embedding in SVGs, or make sure you are using common 

web fonts, or just outline your text.
• Review your SVGs carefully, and make sure you are using the optimal points 

to create a shape. We were able to reduce a world map SVG from 5mb to 
200k by optimising the number of points it used in Adobe Illustrator 
software without creating any visual difference.

• Think carefully if all of your images are necessary.
• Make sure you have reduced your images to 72 dpi—the resolution 

for websites.
• Exporting as IDML and re-importing into the InDesign software at the end 

of your process can cut down the file size as it can clear out unnecessary 
code and get rid of third party plugins.

How to keep my XHTML file size down?

IDML export is a file size detox, but here are some other things you can do before 
exporting:

• Remove any unused objects
• Delete unused styles
• Delete anything left on paste boards or any extra master pages

The XHTML code the Workiva platform produces is clean and optimised, which 
helps with file size and download speed. Essentially, everything not necessary is 
removed. Clients are advised to check with their filing regulator as to what the filing 
size limit is exactly in that jurisdiction. IDML>XHTML also only places repeated 
images as an instance dramatically reducing file size.

Jurisdiction consideration - Find out your file size limit early and check 
that you are staying within this limit.
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Shapes
Please be aware that we do not support all 
aspects of shapes. It is best to test aspects of 
your artwork so that the results can be 
assessed. Shapes can always be easily 
converted to SVG by exporting them from 
the InDesign software to Adobe Illustrator 
software and saving to SVG format from there. 
Then replace the shapes in the InDesign 
software with the SVG images. 

It is best to use a placed SVG instead of multiple 
repeated InDesign shapes as this will reduce the 
file size significantly. 

Be careful of copy and pasting assets within the 
InDesign software. It's always best to 'place' 
assets afresh each time even if they are the 
same asset.

Track changes
If there is non- Workiva content in the InDesign 
file, please ensure that all track changes are 
committed if being used.

Third party plugins
Please ensure these are removed or that the use 
of them does not interfere with Workiva's IDML 
to XHTML converter.

colors
Avoid colors too close. Gradients of colors from 
one to another must be avoided as at present 
this cannot be converted into XHTML.

Spreads
XHTML renders a page at a time so be careful 
with spreads. PDFs can be set to spreads to view 
but this is not the case with XHTML. You can add 
an XBRL viewer with your report and with input 
from your web team, you could add spread 
capability. This however is not available 
open source.

Margins
Mirrored margins have no place in a digital 
medium and are a ‘print only’ feature.

Tabs
Tabs do not exist in XHTML. Tabs must not be 
used for alignment when converting to XHTML.

Columns
ICML exports in galley format. This is a single 
measure, continuous column. It is placed in 
columns in the InDesign software. ICML does 
not export multiple columns. 

In the Workiva platform, you can have a layout of 
up to 7 columns. However, for the ICML export 
to the InDesign software, column layout is not 
essential in the platform as the export sends 
content in galley (one column) format regardless 
of set up in Workiva. The designer takes the 
content and populates the columns in the 
InDesign software. The design from the InDesign 
document will create the XHTML, not the design 
in the Workiva platform.

Alien content
For data assurance, the main report content is 
created in the Workiva platform and this remains 
linked to the InDesign software where the 
designer can design without accidentally 
adjusting the content. Workiva is the master 
document here. However not all content has to 
be in the Workiva platform. So when would extra 
content be added in the InDesign software?

Picture captions 
If design is taking place in the InDesign software, 
images do not need to be added to the Workiva 
platform. Designers can add image captions as 
necessary. These must be styled and are not 
effected on subsequent ICML imports.

Headers and footers
These do not export from the Workiva platform, 
so these need to be created with InDesign 
master pages. 

Tracking and kerning
The InDesign software renders only once, so 
what you see on screen is the exact placement 
of content. On the web, this is different. The web 
renders every time you launch that page so 
designers must be aware of the limitations of 
the web. Justified text for example can have 
different line endings depending on zoom or 
type of browser being used. 

Typesetting
Typesetting takes place in the Workiva platform 
not in the InDesign software. In the Workiva 
platform, do not use a soft return. A soft return is 
when you press Shift Enter. This creates a line 
break rather than a paragraph break. You can 
see your soft and hard returns by pressing the 
Show/Hide non printing characters icon on your 
top ribbon. If words are not to be broken (like in 
a name) use a non-breaking space in between. 

Go to Insert>Symbol>Special 
Characters>Nonbreaking Space. 
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Definition of symbols

InDesign Compatible
These are features of InDesign 
software that are compatible with 
IDML> XHTML export

Avoid
These are features of InDesign 
software that are not compatible 
with IDML> XHTML export

Warning
These are features will need careful 
consideration or application if to be 
rendered in XHTML

Feature information
These are just InDesign features 
that have no bearing on XHTML

Please note that common shortcuts have been added but these may vary due to platform and version of the InDesign software. 
Shortcuts mentioned in this guide are for Macs.
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Align
Window > Object & Layout > Align
This tool can align text boxes or images to left, 
right, horizontally and space items evenly.

Alignment
Alignment as a paragraph style - justified, 
centre, left or right.

Align to page alignment
This feature is not supported in the XHTML 
conversion process.

Anchoring
This is where something is attached to another 
object (i.e. a caption is anchored to the image). 
Move the image and the caption will follow 
automatically except for table cells. Please do 
not use anchored images within text. Placed 
images in table cells are automatically 
anchored and we do support that feature.

Please do not place grouped items in table 
cells. These cannot be rendered.

Anchor Point
Tools Panel > Anchor Point Tool
Gives control over the path of a stroke or 
shape to manually alter its direction or curves.

Asset Links
Window > Links
In the InDesign software, images are linked 
from the desktop. For IDML these images will 
need to be embedded. To do this right click the 
image in the Links Panel and click on Embed 
Link. The image is now a permanent feature of 
the file. Just to note embedded images is a 
requirement of ESEF and should be in base64.

Arrange
Window > Arrange
This allows you to order a selected item to the 
back or front of your document within the 
same layer. This is referred to as the z-index in 
web terminology.

Baseline Grid
Baseline grid is not supported in XHTML. If 
using a baseline grid designers need to push 
their paragraph styles as far as possible to 
replicate the effect. 

Baseline Shift
Baseline is an invisible line where letters sit. 
Baseline shift moves text up or down from the 
baseline. Select text then Option/Shift up or 
down arrow. 

Bleed
Bleed is a print function. The images which are 
required to go to the edge need to actually go 
over the edge and then be cropped by the 
printer. Our convertor will also crop.
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Book
File > New > Book
The InDesign book format is a collection of 
InDesign documents that share the same 
format and can be numbered sequentially. A 
book can have multiple documents. We do not 
support the InDesign book format. The XBRL 
profiler stitches together multiple conversions. 

Bodytext
The only Paragraph style that gets updated 
each time with ICML is called 'Bodytext'. 
Precisely spelled this way. This is because it is 
used to replace the 'Normal' default style. All 
other style names from the Workiva platform 
will NOT update the InDesign styles once they 
are there.

Clipping mask
This is a shape (container) and an image 
(filling). We only support a single object, image 
or shape within the clipping mask. We do not 
support grouped items having a clipping mask 
applied to them.

Comments
Clients/designers should use the Comment 
Function in the Workiva platform and not leave 
comments in the text. At this moment there is 
no way to pass comments to the InDesign 
software.

Colors
Workiva uses RGB colors for web usage. For 
IDML export RGB colors only. 

Top tip: Consider all screen resolutions. Not 
enough color contrast limits web accessibility 
for some users

Character Styles
Character styles are exported via ICML and we 
support character styles in IDML> XHTML 
conversion.

Columns
The Workiva platform can support multiple 
column layout up to seven of like width. 
However, the content from ICML export is 
only one column by default (galley). This can 
populate many columns in the InDesign 
software. The InDesign layout will prevail in 
the XHTML.

Corners (Rounded)
Object > Corner Options
This will change the corner size and shape. 
These are called Squarcles. We support 
rounded corners in IDML>XHTML.
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Drop Cap
This typographic effect is used a great deal in 
print and not so much in XHTML. The drop cap 
can be across multiple lines with one or 
multiple characters at the start of a paragraph. 
We have limited support for drop caps so 
please test thoroughly. The workaround 
advised is to add an image for the drop cap.

Drop Shadow
This effect is not supported in IDML and 
should be avoided.

Descender
A descender letter is a letter that falls under 
the baseline for example ‘y’. The tail of ‘y’ is 
a descender.

Top tip: Subtle variants don’t show on all 
screens

Effects
Object > Effects
Only transparency is supported. Gradients are 
not supported.

Ellipse Tool 
Use this tool to create oval (elliptical) or circle 
(by holding down Shift) which are then ready 
for color and/or text. 

Ellipse Frame Tool
This is used for creating a frame to place an 
image into.

Export
Export to IDML format for XHTML conversion.

For ESEF, fonts need to be 
embedded in the file as base64 
code.

Fonts
The first thing to check is that your client has 
web usage rights to all the fonts used in the 
report. It is advised that the licensing 
agreement contains a web font license. Any 
font (TTF or OTF) can be used because the 
IDML>XHTML will consume and convert 
uploaded fonts. Please make sure they are 
included in the IDML export.

Wingdings or Zapf Dingbats should be used 
with care and tested in XHTML.

Facing Pages
Created in the InDesign software for print 
layouts. Pages in the XHTML output will be 
displayed in order but in single pages only. The 
iXBRL reader can be developed to display 
spreads however.

Fill
Shortcut X
For this tool you set a color and fill a frame.

Top tip: Consider open source fonts for 
licensing and web suitability
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Glyphs
Window > Type & Tables > Glyph
A glyph is a letter/symbol making up a font. 
This palette will show all the available glyphs in 
the selected font. IDML will convert these 
symbols to code (e.g. @ = &#64;).

Gap Tool
Shortcut U
This changes the size of objects but maintains 
the gap between them.

Gradients
A gradient is a flowing blend between one 
color and another or from one tint to another 
tint of the same color. We cannot accurately 
convert InDesign gradients to XHTML.

Gradient Feather Tool
Shift G
This tool allows you to fade an object/shape 
from opaque to transparent. Point to be aware 
of is that subtle gradients do not show up on 
the web due to screen resolution.

Gradient Swatch Tool
Shortcut G
You can adjust your gradient here.

Grids - Baseline Grid
View > Extras > Show Baseline Grid
The baseline grid is a framework that is used to 
align text. It is only shown in the printable area. 
It is not supported in IDML>XHTML.

Grids - Document Grid
View > Extras > Show Document Grid
This grid extends to the non-printable area 
around the page (the pasteboard) so that 
attributes can be stored for later use.

Group
Object > Group / Ungroup
The Group tool collects any item in the 
InDesign software and maintains XY 
coordinates when moving or rotating the 
group. XHTML does not support grouped items 
therefore you are required to ungroup all 
grouped items before conversion. 

Guides
Layout > Create Guides
You can manually drag guides from the ruler 
bar. This is used to create individual guides 
rather than the document grid. 
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Hand Tool
Shortcut H
This tool is used to grab the actual document 
and move around in your screen view between 
the pages or spreads.

Hyphenate
Located in the Paragraph panel
If you tick the hyphenate option in a paragraph 
style, it allows words to break at the end of the 
line across to the new line automatically. This 
is an InDesign function and is partially 
supported in XHTML conversion.

In certain languages the management of 
hyphenation is very important. It is advised 
that designers who are using those languages 
test thoroughly the IDML>XHTML convertor to 
make sure they get the effects that they want.

Hierarchical Styles
We support inheritancy (based on) in style 
pallets, paragraph, character and cell.

Info
Window > Info
Highlight text and then click window>info and 
it displays how many paragraphs, lines, words 
and characters. This is a good tool for clients 
to know how many words they need to fill a 
text area.

Intent
File > New Document > Intent
This is where you can set the intent of the 
document (e.g. print, web or mobile). This 
creates page sizes suitable for the use or 
platform. On newer versions web and mobile 
are tabs where you can set the size. For ESEF, 
the report is shown in a pdf style format so the 
web or mobile page setup is not necessary. 

Kerning
Character palette or Command T
This is where you can increase or decrease the 
space between individual characters. Kerning 
can be set in the InDesign software only. There 
is a word spacing function in the platform but 
this is not exported in ICML. It is unclear as yet 
as to how far we will go to support kerning in 
IDML to XHTML. It is certain that we will 
support it as part of a style and is certain that 
we will not support it as an override. This 
means that designers who break the ICML link 
to use kerning techniques for widow 
management cannot do this anymore. 
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Leading/Line Feed
Leading is the space vertically between lines of 
type. It is measured from one baseline to the 
next. The InDesign default is 120%. You can 
change leading in the InDesign paragraph 
styles panel. 

Layers 
Window > Layers
Layers help organise a document. The visibility 
of each layer can be turned on or off. You can 
lock a layer to prevent items on that layer from 
being selected. It is often used by designers 
when coming up with design visuals for clients. 
Layers can also be used for comments. Delete 
all hidden layers and layers used for admin 
purposes. 

Top tip: Please remove hidden layers 
before conversion to XHTML

Line Numbers
Some designers add line numbers as a 
development feature in the InDesign software 
often on a hidden layer. Designers should 
delete these before IDML creation.

Line Tool
Shortcut \
This creates a single line. It can be edited in 
the Stroke panel (window>stroke) i.e. weight, 
color, etc.

Holding down the shift key keeps the line 
vertical or horizontal.

Links (Assets)
Window > Links
In the InDesign software, images are linked 
from the desktop folder. For IDML these 
images will need to be embedded. To do this 
right click the image in the link panel and click 
on Embed Link. The image is now a permanent 
feature of the file. 

Liquid Layout 
Window > Interactive > Liquid Layout
This allows for different page sizes across your 
document and must not be used for IDML 
export.

Lists
The InDesign software only supports 6 levels 
of lists whereas the Workiva platform supports 
more. 

Many designers are moving away from 
encapsulated lists. If you need to use more 
than 6 levels, just create the right number of 
paragraph styles with the appropriate indent 
and space above/below. 

Lock 
Object > Lock
This locks elements so that you cannot 
accidentally move them. Designers must 
unlock before export.
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Margins
Layout > Margins and Columns
With a new document use this function on 
your master page and this will be set 
throughout the document. Click on each page 
if you want to adjust the pages later on.

Markers
Type > Insert Special Character > Markers (Page 
numbering)
Here you need to create a text frame then click 
on markers. If this is done on the master 
document, it will appear on all pages that have 
been created from the master page. We 
support page numbers but do not support text 
variables. 

Master Pages 
Window > Pages
Master pages are simply templates set up with 
common attributes e.g. headers and footers, 
page numbering, logo etc. You can create 
more masters (e.g. left and right-hand 
templates for spreads). You drag the master 
page into the Page panel to place those items.

Measure Tool
Shortcut K
This tool measures between two points and 
appears in the information bar. 

Negative indents
Negative indents are not supported in XHTML.

Nested Styles
Far right of application bar > Drop Caps and 
Nested styles 
A nested style is a style within a paragraph 
style. It will effectively override the paragraph 
style. This is not supported together with other 
style hierarchy.

Notes
Type > Notes
Here you can leave notes or comments for 
review.

Numbering & Section Options
Layout > Numbering & Section Options
When creating a large report, this helps with 
navigation. 

The sections are shown in the thumbnails in 
the pages panel. We support automated page 
numbering.

Object 
Top menu > Object 
An object in the InDesign software is anything 
that can be edited ie text frame or image. With 
this drop down menu you can send the object 
to back or front, add effects like a drop shadow 
or transparency. We support limited attributes 
of object styles. Border, background and color.

Observed regions
The Workiva platform uses the concept of 
observed regions for a number of reasons 
including XBRL tagging. This is reflected in the 
InDesign software using the tagging panel and 
can be seen as multi-colored squared brackets 
around the ICML content. These brackets do 
not affect the design in any way. 

When splitting a number of text frames, please 
do not split across an observed region, 
denoted by the square brackets shown below.

[open/.… split..../closed] 
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Optical Margin Alignment 
Top menu > Window > Type & Tables > Story
This tool will shift characters like speech 
marks to create a cleaner line. See example 
below. We do not support this. 

Optical Margin example

Overprint
View > Overprint Preview
Spot colors are used when color accuracy is 
critical. This preview will show you more 
accurately how the colors will actually look in 
print. We do not support spot colors. They can 
be changed in the InDesign software in the 
color palette affecting the linked ICMLs.

Package
File > Package
This is used when sending the InDesign file to 
somebody else or good practice for your own 
information. This brings all the assets together 
into one folder.

Page Numbering
In the pages panel, double click master pages. 
Add a text frame large enough for your biggest 
number. Add a text frame to left and right 
master pages if applicable. Add text, if 
required, for example ‘page’ then position 
where you want the number to go then 

Type > Insert Special Character > Markers > 
Current Page Number

By default, the numbering is 1,2,3 etc. 

For different numbering - Layout > Numbering 
& Section Options

Pages Panel 
Window > Pages
You can navigate through your pages using the 
Pages Panel. Here you can add more pages, 
delete or duplicate.

Page Tool 
Shift P
This just changes the page size of one page in 
your document. It will not affect the other 
pages. 

Paragraph Panel
Window > Type & Tables > Paragraph
This is used for individual paragraphs rather 
than using paragraph styles. We do not 
support overrides.

Paragraph Formatting Controls
Top Application Bar 
This contains lots of style controls. Access by 
clicking on the ‘A’ which is top left. We do not 
support overrides.

Paste/paste into
Edit > Paste / Paste in Place
Please place all images. Do not cut and place 
multiples of an image. This includes pasting 
into shapes.
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Pasteboard
View > Entire Pasteboard
The Pasteboard is the whole area including the 
area for non-printed content.

Pen Tool 
Shortcut P
This creates custom lines.

Pencil Tool
Shortcut N
This creates lines as the pen tool but with 
more flexibility.

Place
File > Place
Images should always be placed rather than 
pasted. Images should be placed at 100% 
ideally for optimal file size. Images should 
also be fitted to the frame that they occupy. 
In other words, images should be cropped 
to the frame.

Plugins
All plugins should be disconnected before 
IDML export.

Polygon Tool
Tools Panel > Right Click > Polygon
This is supported. Please be careful about 
placing grouped items within a polygon as this 
will not be converted.

Preflight 
Window > Output > Preflight
Preflight checks for errors before exporting 
and packaging in a zip file - things like missing 
files or fonts, low-resolution images and text 
overmatter.

Profiles
Edit > Assign Profiles
Here you can alter the colors of your 
document without converting colors (e.g. RGB 
to CMYK). 

Top tip: Clear all pasteboard items for 
a quicker conversion 

Rectangle Tool
Shortcut M
This creates a rectangle frame ready for text/
color etc. Holding down the shift key creates a 
square. We support this as a text or image 
frame.

Relink
Window > Links or bottom of links panel
Images etc that have been renamed/moved 
can create an error and it is here where you 
can relink.

Revert
File > Revert
This goes back to the previous version of your 
document. Make sure that you have the 
current ICML.

Rotate Spread
View > Rotate Spread
This is only for working on your document. It 
does not alter print or IDML export.

Rotate Content
We support rotated content

Rulers
View > Show Rulers
Rulers can be dragged across from top down 
or left across.
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Scale Tool 
Shortcut S
Grab the frame handle and resize.

Scissors Tool
Shortcut C
This cuts a frame or path.

Screen Mode 
View > Screen Mode or W
This switches between normal editing mode 
and preview.

Separations
Window > Output > Separations Preview
This shows all the colors which are being used 
and can check when one color is being printed 
over another (e.g. knockout or overprint). This 
is an InDesign software only feature.

Shear Tool
Shortcut O/ Object > Transform
This changes shapes to create a more 3D 
effect by slanting an object. This is supported.

Slug
File > New Document > Bleed and Slug
Slug is a function not often used. It is used for 
leaving instructions outside the printed area 
and outside the Bleed area. 

Split Story Script
For IDML export, do not split a bulleted item 
across text frames. The list can be in multiple 
frames but not an individual bullet.

Smooth Tool
Tools Panel > Under Pencil Tool drop-down 
menu
This removes/simplifies anchor points on 
shapes. When placing many shapes in a 
document, designers need to be aware of the 
number of points in a shape. It is best to 
optimise these for successful conversion and 
optimal file size.

Spreads
Please note that for IDML>XHTML, we process 
pages, page by page. iXBRL readers can display 
spreads although this will need some web 
development from your team. Please note that 
spreads over three pages cannot be used.

Stroke
Window > Stroke
With this panel, the appearance of lines can be 
altered.

Styles
Window > Styles
This should be used for setting Paragraph, 
Character and Cell. This is a time saver and 
should be used consistently across your whole 
document. 

Please note that only the border and 
background of object styles are supported.

SVG
ESMA doesn't allow the <object> tag or <svg> 
tag so inline presentation is not allowed as we 
can't read the fonts.

To ensure that the SVG file appears correctly, 
if embedded in a web page:

1. open the SVG file in an illustration program

2. convert all font characters to outline paths

3. re-export the SVG file and embed that file

Alternatively, you can use web fonts to ensure 
that the necessary fonts are available on the 
web server.

Swatches
Window > color > Swatches
This panel is your library of colors or tints. 
Once a color is applied, like paragraph styles, 
edits made to a color choice will change all 
instances of that color across the document. 
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Table Measurements
The Workiva platform measures tables in 
pixels. The InDesign software measures by 
default in points, but can also do mm, picas 
and other forms of measurements. To set the 
correct body text width in InDesign for your 
desired table width please set In Design units 
to pixels and therefore you have parity with 
the platform.

Table 
Table tab in the top menu.
Here there are the usual features of the 
number of columns, rows including height and 
width. We do not support table overrides in any 
form for XHTML export.

Table Cells
Avoid putting a text frame within a table cell. 
We do not support this. 

Text color - inherited
We do not support inherited text colors. This 
is a feature of the InDesign software often 
using rule above/below. Please specify an 
actual color from the color palette.

Text frames
Text within a NON-rectangular text frame will 
not be supported. Please only use rectangular 
text frames.

Tabs
Tabs must not be used. Ever! 

Text Threads
View > Extras > Show Text Threads
Text threads show the text frames that are 
linked together to create one single flow of 
text. You can link a text frame by clicking on 
the square in the bottom right corner of the 
text box and then clicking again in the 
following text frame. All linked text frames 
must be split before conversion.

Text Wrap 
Window > Text Wrap
This panel wraps text around images or 
shapes. We do not support this. 

Tracking
Windows > Type and Tables > Character
This reduces or increases the spaces between 
characters in a sequence of text. This tracks 
everything back and adjusts the whitespace 
proportionally back. This can be done as part 
of character and paragraph but cannot be 
accepted as an override.

Transform
Object > Transform
Here you can flip horizontally or vertically, 
scale, rotate or shear. Shear is when you slant 
an object. If an image converts incorrectly 
please check any transform done in InDesign.

Type Tool 
Shortcut T
This tool creates a text frame

Use the Type Tool to create a text frame (just 
click and drag) for inserting text or click once 
on an existing frame or shape to transform it 
into a text frame. 

Type on a Path Tool
Shift T
First you need to use the Pen Tool to create a 
path. Then you click the Type of Path Tool, go 
over to your path and click just once where 
you want the text to start. You then type and 
your letters will follow the path.

Tabs do not exist on the web!

53

T

Compatible Avoid Warning Info



Units & Increments
Preferences > Units & Increments
You can set your preferences here for 
measurements. Pixels are usually used for web 
design so this should be selected for parity 
with the Workiva platform.

Variables
Type > Text Variables
Text variables can be used within text and text 
frames. These changes are dependent on a 
number of factors. Pagination, section, dates, 
running headers are some ways in which they 
are used.

We will be discussing whether we will support 
some of these items in certain circumstances.

Wingdings
Not all browsers understand Wingdings, 
Webdings and Zapf Dingbats. Best to avoid. 
There is limited unicode support. 

Workspace
Window > Workspace
Workspace controls what panels you have 
available on your screen. You can click back to 
‘Essentials’ to tidy up your workspace.
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XML
File > Import XML
XML or Extensible Markup Language is a 
toolset for data. The InDesign software can 
work with XML files. Using this structure you 
can tag the content of your InDesign file and 
use this structured data for use in other 
applications.

XML tags can be mapped to styles in order to 
facilitate the formatting of this content. There 
are systems that work in this way.

The ICML exporter uses the InDesign 
software’s built-in XML structure to facilitate 
the passing of observed regions from the 
Workiva platform to ICML, to be retained in the 
InDesign software, and exported via IDML for 
conversion to XHTML. These InDesign tags are 
used to populate XBRL at conversion time. 

Zapf Dingbats
Not all browsers understand Zapf Dingbats. 
Best to avoid.

Zoom Browser
Beware that some browsers complete values 
based on zoom levels. E.g. line rule weights 
may look different based on browser and scale 
used.

Zoom Tool
Shortcut Z
This tool does exactly as it says and it’s also 
great for moving around a spread.
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All information, content, and materials available in this document are 
for general informational purposes only. The content on this posting 
is provided "as is;" no representations are made that the content is 

error-free or up to date. Designers should test their design in XHTML 
often and keep back up files at all times.

Written and designed by the Design Centre of Excellence, Workiva

The information contained herein is proprietary to Workiva and cannot be copied,
 published, or distributed without express prior written consent. 

Copyright 2022 Workiva Inc. 
Workiva is a registered trademark of Workiva Inc. 

All rights reserved.

Adobe, Illustrator, InDesign and Photoshop are either registered trademarks or trademarks of Adobe in the United States and/or 
other countries. Microsoft and Word are trademarks of the Microsoft group of Companies. XBRL® and iXBRL™ are trademarks o 
XBRL International, Inc. All rights reserved. The XBRL™/® standards are open and freely licensed by way of the XBRL International 
License Agreement. Our use of these trademarks is permitted by XBRL International in accordance with the XBRL International 
Trademark Policy.
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Workiva Confidential and Proprietary Information

Support contacts
For questions, reach out to your Customer Success manager, or our Support Team.

24/7 Helpdesk

United Kingdom - +44 8000885141 France - +33 801840098 US - 1-877-934-8435

From Europe: 00-800-5005-0080 From the US: 1-800-706-6526

A full list of our global support telephone numbers can be located here Or email our Support Team directly via support@workiva.com

Workiva Inc. (NYSE: WK) simplifies complex work for thousands of organisations worldwide. Customers trust Workiva’s open, intelligent, and intuitive platform to connect 
data, documents and teams. The results: improved efficiency, greater transparency and less risk.
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